4.0-stable build 96

Revision r18709 (build 96 started on 2019-10-17T14:09:08Z)


originally caused by:
 Started by an SCM change
Building in workspace /var/lib/jenkins/workspace/4.0-stable/DATABASE_ADAPTER/mysql/RUBY_VER/ruby-2.4
Updating http://svn.redmine.org/redmine/branches/4.0-stable at revision '2019-10-17T07:09:08.181 -0700'
U         config/locales/ru.yml
 U        .
At revision 18709

[ruby-2.4] $ /bin/sh -xe /tmp/jenkins4646503295103155082.sh
+ PATH=/var/lib/jenkins/ruby/ruby-2.4/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games rake -f lib/tasks/ci.rake config/database.yml BRANCH=4.0-stable
[ruby-2.4] $ /bin/sh -xe /tmp/jenkins3179859927889901798.sh
+ PATH=/var/lib/jenkins/ruby/ruby-2.4/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games bundle update
The latest bundler is 2.1.0.pre.2, but you are currently running 1.15.3.
To update, run `gem install bundler --pre`
The dependency tzinfo-data (>= 0) will be unused by any of the platforms Bundler is installing for. Bundler is installing for ruby but the dependency is only for x86-mingw32, x64-mingw32, x86-mswin32. To add those platforms to the bundle, run `bundle lock --add-platform x86-mingw32 x64-mingw32 x86-mswin32`.
Fetching gem metadata from https://rubygems.org/.............
Fetching version metadata from https://rubygems.org/..
Fetching dependency metadata from https://rubygems.org/.
Resolving dependencies...
Using rake 13.0.0
Using concurrent-ruby 1.1.5
Using i18n 0.7.0
Using minitest 5.12.2
Using thread_safe 0.3.6
Using builder 3.2.3
Using erubi 1.9.0
Using mini_portile2 2.4.0
Using crass 1.0.5 (was 1.0.4)
Using rack 2.0.7
Using nio4r 2.5.2
Using websocket-extensions 0.1.4
Using mini_mime 1.0.2
Using method_source 0.9.2
Using thor 0.20.3
Using arel 9.0.0
Using mimemagic 0.3.3
Using public_suffix 4.0.1
Using bundler 1.15.3
Using childprocess 3.0.0
Using csv 3.0.9
Using docile 1.1.5
Using htmlentities 4.3.4
Using json 2.2.0
Using metaclass 0.0.4
Using mysql2 0.5.2
Using net-ldap 0.16.1
Using puma 3.12.1
Using ruby-openid 2.3.0
Using rbpdf-font 1.19.1
Using redcarpet 3.4.0
Using request_store 1.0.5
Using rmagick 2.16.0
Using rouge 3.3.0
Using rubyzip 2.0.0
Using simplecov-html 0.10.2
Using yard 0.9.20
Using tzinfo 1.2.5
Using nokogiri 1.10.4
Using rack-test 1.1.0
Using sprockets 3.7.2
Using websocket-driver 0.7.1
Using mail 2.7.1
Using marcel 0.3.3
Using addressable 2.7.0
Using mocha 1.9.0
Using rack-openid 1.4.2
Using rbpdf 1.19.8
Using selenium-webdriver 3.142.6
Using simplecov 0.14.1
Using activesupport 5.2.3
Using loofah 2.3.0
Using xpath 3.2.0
Using css_parser 1.7.0
Using rails-dom-testing 2.0.3
Using globalid 0.4.2
Using activemodel 5.2.3
Using rails-html-sanitizer 1.3.0
Using capybara 2.18.0
Using roadie 3.5.1
Using activejob 5.2.3
Using activerecord 5.2.3
Using actionview 5.2.3
Using actionpack 5.2.3
Using actioncable 5.2.3
Using actionmailer 5.2.3
Using railties 5.2.3
Using activestorage 5.2.3
Using sprockets-rails 3.2.1
Using actionpack-xml_parser 2.0.1
Using roadie-rails 1.3.0
Using rails 5.2.3
Bundle updated!
[ruby-2.4] $ /bin/sh -xe /tmp/jenkins5505187908981633700.sh
+ PATH=/var/lib/jenkins/ruby/ruby-2.4/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games bundle exec rake ci:about ci:setup RAILS_ENV=test
Ruby version: 2.4.1-p111 (2017-03-22) [i686-linux]
svn: E155036: Please see the 'svn upgrade' command
svn: E155036: The working copy at '/var/lib/jenkins/workspace/4.0-stable/DATABASE_ADAPTER/mysql/RUBY_VER/ruby-2.4'
is too old (format 8) to work with client version '1.9.3 (r1718519)' (expects format 31). You need to upgrade the working copy first.

Database 'ci_40stable_ruby24_dev' already exists
Database 'ci_40stable_ruby24_test' already exists
[ruby-2.4] $ /bin/sh -xe /tmp/jenkins7367884765946052801.sh
+ PATH=/var/lib/jenkins/ruby/ruby-2.4/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games bundle exec rake test
svn: E155036: Please see the 'svn upgrade' command
svn: E155036: The working copy at '/var/lib/jenkins/workspace/4.0-stable/DATABASE_ADAPTER/mysql/RUBY_VER/ruby-2.4'
is too old (format 8) to work with client version '1.9.3 (r1718519)' (expects format 31). You need to upgrade the working copy first.

Deprecation warning: Net::LDAP::ConnectionRefused will be deprecated. Use Errno::ECONNREFUSED instead.
Deprecation warning: Net::LDAP::ConnectionRefused will be deprecated. Use Errno::ECONNREFUSED instead.
(Test LDAP server not configured)
Bazaar non ASCII output test cannot run on this environment.
Encoding.locale_charmap: UTF-8
Skipping LDAP tests.
Run options: --seed 8890

# Running:

...........................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................SS...........................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................

Finished in 534.230911s, 8.8202 runs/s, 40.3552 assertions/s.
4712 runs, 21559 assertions, 0 failures, 0 errors, 2 skips

You have skipped tests. Run with --verbose for details.
Finished: SUCCESS