trunk build 702

Revision r18784 (build 702 started on 2019-10-19T23:36:07Z)


originally caused by:
 Started by an SCM change
Building in workspace /var/lib/jenkins/workspace/trunk/DATABASE_ADAPTER/sqlite3/RUBY_VER/ruby-2.5
Updating http://svn.redmine.org/redmine/trunk at revision '2019-10-19T16:36:07.580 -0700'
U         config/locales/lt.yml
U         config/locales/sr-YU.yml
U         config/locales/ro.yml
U         config/locales/lv.yml
U         config/locales/zh.yml
U         config/locales/ca.yml
U         config/locales/pt.yml
U         config/locales/pt-BR.yml
U         config/locales/tr.yml
U         config/locales/ru.yml
U         config/locales/en-GB.yml
U         config/locales/id.yml
U         config/locales/el.yml
U         config/locales/gl.yml
U         config/locales/ar.yml
U         config/locales/es-PA.yml
U         config/locales/cs.yml
U         config/locales/es.yml
U         config/locales/mk.yml
U         config/locales/et.yml
U         config/locales/zh-TW.yml
U         config/locales/eu.yml
U         config/locales/ko.yml
U         config/locales/az.yml
U         config/locales/mn.yml
U         config/locales/it.yml
U         config/locales/sk.yml
U         config/locales/sl.yml
U         config/locales/uk.yml
U         config/locales/sq.yml
U         config/locales/da.yml
U         config/locales/sr.yml
U         config/locales/fa.yml
U         config/locales/bg.yml
U         config/locales/de.yml
U         config/locales/sv.yml
U         config/locales/ja.yml
U         config/locales/he.yml
U         config/locales/fi.yml
U         config/locales/bs.yml
U         config/locales/fr.yml
U         config/locales/nl.yml
U         config/locales/hr.yml
U         config/locales/pl.yml
U         config/locales/th.yml
U         config/locales/no.yml
U         config/locales/hu.yml
U         config/locales/vi.yml
At revision 18784

[ruby-2.5] $ /bin/sh -xe /tmp/jenkins7749589011563611383.sh
+ PATH=/var/lib/jenkins/ruby/ruby-2.5/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games rake -f lib/tasks/ci.rake config/database.yml BRANCH=trunk
[ruby-2.5] $ /bin/sh -xe /tmp/jenkins773611733965430179.sh
+ PATH=/var/lib/jenkins/ruby/ruby-2.5/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games bundle update
The dependency tzinfo-data (>= 0) will be unused by any of the platforms Bundler is installing for. Bundler is installing for ruby but the dependency is only for x86-mingw32, x64-mingw32, x86-mswin32. To add those platforms to the bundle, run `bundle lock --add-platform x86-mingw32 x64-mingw32 x86-mswin32`.
The dependency ffi (>= 0) will be unused by any of the platforms Bundler is installing for. Bundler is installing for ruby but the dependency is only for x86-mingw32, x64-mingw32, x86-mswin32. To add those platforms to the bundle, run `bundle lock --add-platform x86-mingw32 x64-mingw32 x86-mswin32`.
Fetching gem metadata from https://rubygems.org/..........
Fetching gem metadata from https://rubygems.org/.
Resolving dependencies....
Using rake 13.0.0
Using concurrent-ruby 1.1.5
Using i18n 1.6.0
Using minitest 5.12.2
Using thread_safe 0.3.6
Using tzinfo 1.2.5
Using activesupport 5.2.3
Using builder 3.2.3
Using erubi 1.9.0
Using mini_portile2 2.4.0
Using nokogiri 1.10.4
Using rails-dom-testing 2.0.3
Using crass 1.0.5
Using loofah 2.3.0
Using rails-html-sanitizer 1.3.0
Using actionview 5.2.3
Using rack 2.0.7
Using rack-test 1.1.0
Using actionpack 5.2.3
Using nio4r 2.5.2
Using websocket-extensions 0.1.4
Using websocket-driver 0.7.1
Using actioncable 5.2.3
Using globalid 0.4.2
Using activejob 5.2.3
Using mini_mime 1.0.2
Using mail 2.7.1
Using actionmailer 5.2.3
Using method_source 0.9.2
Using thor 0.20.3
Using railties 5.2.3
Using actionpack-xml_parser 2.0.1
Using activemodel 5.2.3
Using arel 9.0.0
Using activerecord 5.2.3
Using mimemagic 0.3.3
Using marcel 0.3.3
Using activestorage 5.2.3
Using public_suffix 4.0.1
Using addressable 2.7.0
Using ast 2.4.0
Using bundler 1.17.1
Using regexp_parser 1.6.0
Using xpath 3.2.0
Using capybara 3.25.0
Using childprocess 3.0.0
Using css_parser 1.7.0
Using csv 3.1.2
Using docile 1.3.2
Using htmlentities 4.3.4
Using jaro_winkler 1.5.3
Using json 2.2.0
Using metaclass 0.0.4
Using mini_magick 4.9.5
Using mocha 1.9.0
Using net-ldap 0.16.1
Using parallel 1.18.0
Using parser 2.6.5.0
Using puma 3.12.1
Using ruby-openid 2.9.2
Using rack-openid 1.4.2
Using sprockets 3.7.2
Using sprockets-rails 3.2.1
Using rails 5.2.3
Using rainbow 3.0.0
Using rbpdf-font 1.19.1
Using rbpdf 1.20.1
Using redcarpet 3.5.0
Using request_store 1.0.5
Using roadie 3.5.1
Using roadie-rails 2.1.0
Using rouge 3.12.0
Using ruby-progressbar 1.10.1
Using unicode-display_width 1.6.0
Using rubocop 0.75.1
Using rubocop-performance 1.5.0
Using rubocop-rails 2.3.2
Using rubyzip 2.0.0
Using selenium-webdriver 3.142.6
Using simplecov-html 0.10.2
Using simplecov 0.17.1
Using sqlite3 1.4.1
Using yard 0.9.20
Bundle updated!
[ruby-2.5] $ /bin/sh -xe /tmp/jenkins6301980212921319190.sh
+ PATH=/var/lib/jenkins/ruby/ruby-2.5/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games SCMS=subversion,git,mercurial,filesystem,bazaar,cvs bundle exec rake ci:about ci:setup db:environment:set RAILS_ENV=test
Ruby version: 2.5.3-p105 (2018-10-18) [i686-linux]
svn: E155036: Please see the 'svn upgrade' command
svn: E155036: The working copy at '/var/lib/jenkins/workspace/trunk/DATABASE_ADAPTER/sqlite3/RUBY_VER/ruby-2.5'
is too old (format 8) to work with client version '1.9.3 (r1718519)' (expects format 31). You need to upgrade the working copy first.

Database 'db/ci_trunk_ruby25_dev.sqlite3' already exists
Database 'db/ci_trunk_ruby25_test.sqlite3' already exists
[ruby-2.5] $ /bin/sh -xe /tmp/jenkins2395804973000512398.sh
+ PATH=/var/lib/jenkins/ruby/ruby-2.5/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games bundle exec rake test
svn: E155036: Please see the 'svn upgrade' command
svn: E155036: The working copy at '/var/lib/jenkins/workspace/trunk/DATABASE_ADAPTER/sqlite3/RUBY_VER/ruby-2.5'
is too old (format 8) to work with client version '1.9.3 (r1718519)' (expects format 31). You need to upgrade the working copy first.

Deprecation warning: Net::LDAP::ConnectionRefused will be deprecated. Use Errno::ECONNREFUSED instead.
Deprecation warning: Net::LDAP::ConnectionRefused will be deprecated. Use Errno::ECONNREFUSED instead.
(Test LDAP server not configured)
Bazaar non ASCII output test cannot run on this environment.
Encoding.locale_charmap: UTF-8
Skipping LDAP tests.
Run options: --seed 18506

# Running:

......................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................S.................................................................................................................................................................................................................................................................................................................S.............................................................................................................................................................S......................................................................................S.................................................................................................................................................................................................................................................................................................F

Failure:
MailerTest#test_reminders [/var/lib/jenkins/workspace/trunk/DATABASE_ADAPTER/sqlite3/RUBY_VER/ruby-2.5/test/unit/mailer_test.rb:652]:
"Bug #3: Error 281 when updating a recipe (5 days late)" not found in "1 issue(s) that are assigned to you are due in the next 42 days::

* eCookbook - Bug #3: Error 281 when updating a recipe (6 days late)

View all issues (2 open)
http://localhost:3000/issues?assigned_to_id=me&set_filter=1&sort=due_date%3Aasc

-- 
You have received this notification because you have either subscribed to it, or are involved in it.
To change your notification preferences, please click here: http://hostname/my/account
"

bin/rails test test/unit/mailer_test.rb:646

............F

Failure:
MailerTest#test_reminders_language_auto [/var/lib/jenkins/workspace/trunk/DATABASE_ADAPTER/sqlite3/RUBY_VER/ruby-2.5/test/unit/mailer_test.rb:672]:
"Bug #3: Error 281 when updating a recipe (En retard de 5 jours)" not found in "1 demande(s) qui vous sont assignées arrivent à échéance dans les 42 prochains jours ::

* eCookbook - Bug #3: Error 281 when updating a recipe (En retard de 6 jours)

Voir toutes les demandes (2 ouvertes)
http://localhost:3000/issues?assigned_to_id=me&set_filter=1&sort=due_date%3Aasc

-- 
You have received this notification because you have either subscribed to it, or are involved in it.
To change your notification preferences, please click here: http://hostname/my/account
"

bin/rails test test/unit/mailer_test.rb:663

.......F

Failure:
MailerTest#test_reminders_for_users [/var/lib/jenkins/workspace/trunk/DATABASE_ADAPTER/sqlite3/RUBY_VER/ruby-2.5/test/unit/mailer_test.rb:701]:
"Bug #3: Error 281 when updating a recipe (5 days late)" not found in "1 issue(s) that are assigned to you are due in the next 42 days::

* eCookbook - Bug #3: Error 281 when updating a recipe (6 days late)

View all issues (2 open)
http://localhost:3000/issues?assigned_to_id=me&set_filter=1&sort=due_date%3Aasc

-- 
You have received this notification because you have either subscribed to it, or are involved in it.
To change your notification preferences, please click here: http://hostname/my/account
"

bin/rails test test/unit/mailer_test.rb:693

.............................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................SS..............................................................................................................................................................................................................................................................................................................................................................................................................S...................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................

Finished in 384.652838s, 12.7440 runs/s, 58.2889 assertions/s.
4902 runs, 22421 assertions, 3 failures, 0 errors, 7 skips

You have skipped tests. Run with --verbose for details.
Build step 'Execute shell' marked build as failure
Finished: FAILURE