Defect #10199

No wiki section edit when title contains code

Added by Elmer de Looff almost 3 years ago. Updated almost 3 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:Wiki
Target version:1.3.2
Resolution:Fixed Affected version:1.3.1

Description

When viewing a wiki entry, the section edit links next to the heading will end up editing the section above the link. Expected behavior would be to edit the section that the heading starts.

Additionally, there is no edit link for the last section. Manually browsing to the section one number higher does let you edit that section.

Rack and rails versions in case they are relevant:
  • rack (1.1.3)
  • rails (2.3.14)

Related issues

Related to Feature #2222: Single section edit. Closed 2008-11-21

Associated revisions

Revision 8841
Added by Jean-Philippe Lang almost 3 years ago

Fixed: wrong section edit links when a heading contains inline code (#10199).

History

#1 Updated by Etienne Massip almost 3 years ago

Actually it allows to edit the section which is below the header.

#2 Updated by Elmer de Looff almost 3 years ago

Apologies, there seems to be something more specific at hand.

It seems like the section link will be skipped if the header contains additional Textile markup. In my case, I had a word in my title wrapped in @ signs, which causes Redmine to skip the edit link. It doesn't seem to matter whether there is "normal" text following the code marked word, the section edit link will not be there.

#3 Updated by Elmer de Looff almost 3 years ago

An example of this can be found here: code tags remove section edit link

#4 Updated by Etienne Massip almost 3 years ago

Elmer de Looff wrote:

An example of this can be found here: code tags remove section edit link

I don't have the wiki edit permission.

#5 Updated by Elmer de Looff almost 3 years ago

How would I go about giving you permission.. Is there a general group I could add as developer to the wiki? There seem to be no administration options to give anonymous editing privileges to the Wiki :(

#6 Updated by Elmer de Looff almost 3 years ago

Hmm, it's probably faster for you to try this yourself than figuring out how to have a look at the same demo Redmine wiki. The necessary example wiki format can be found here: http://pastebin.com/8QT7CthS

#7 Updated by Etienne Massip almost 3 years ago

  • Subject changed from Wiki section edit links off-by-one to No wiki section edit when title contains code
  • Status changed from New to Confirmed
  • Target version set to Candidate for next minor release

Didn't see your comment in note#2, sorry.

#8 Updated by Etienne Massip almost 3 years ago

Probably related to note#31 of #2222.

#9 Updated by Jean-Philippe Lang almost 3 years ago

  • Status changed from Confirmed to Resolved
  • Assignee set to Jean-Philippe Lang
  • Target version changed from Candidate for next minor release to 1.3.2
  • Resolution set to Fixed

Fixed in r8841.

#10 Updated by Jean-Philippe Lang almost 3 years ago

  • Status changed from Resolved to Closed

Merged.

Also available in: Atom PDF