Feature #1038

Add repo url to repository view

Added by Carl Nygard over 9 years ago. Updated over 7 years ago.

Status:ClosedStart date:2008-04-10
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:SCM
Target version:-
Resolution:Duplicate

Description

It's useful to know exactly which part of the repo a project is attached to. This patch adds the repo url from the configuration to the top "crumbs"

redmine-repourl.patch Magnifier (562 Bytes) Carl Nygard, 2008-04-10 20:11


Related issues

Duplicates Redmine - Patch #232: SCM URL/ROOT Information on Repository Page New

History

#1 Updated by Karl DeBisschop over 9 years ago

Nice idea.

In our case, however, redmine accesses the SVN as file whereas we want the users to see the https:// form of the repo.

I'm rather out of my element in ruby. What would it take to allow the published URL to be different than the internal access URL?

#2 Updated by Alexandre Garino about 9 years ago

Karl DeBisschop wrote:

Nice idea.

In our case, however, redmine accesses the SVN as file whereas we want the users to see the https:// form of the repo.

I'm rather out of my element in ruby. What would it take to allow the published URL to be different than the internal access URL?

+1

We should have an internal repository url used by redmine bringing browsing capabilities and an external repository url displayed on the home page. A workaround is to create a custom field on project (e.g. SCM URL).

#3 Updated by Jean-Philippe Lang about 9 years ago

  • Target version deleted (0.8)

#4 Updated by Holger Just over 7 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

This is a duplicate of #232.

The functionality is provided by my Redmine Checkout plugin

Also available in: Atom PDF