Feature #10864

Define initial issue status in workflow setting

Added by Mirko Geissler over 5 years ago. Updated over 4 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues workflow
Target version:-
Resolution:Duplicate

Description

Excuse me if this is already possible (I really din´t find a way to achieve it):

I would like to be able to limit the available status set when creating a new issue ticket. Currently this is implicitly defined by the follow up statuses of the "New" state (default state).

What I would like to propose is the following:
In the workflow table please add a new top most row (without a "from" status) which defines which initial statuses are available when creating a new issue ticket.

This would be completely consistent with the rest of the table and would make the workflow management more flexible and clear.

It seems that this change touches the "default status" setting in a way. I´m actually not sure how to deal with this globally defined status property.

Comments are much appreciated.


Related issues

Duplicates Redmine - Feature #5816: New issue initial status should be settable in workflow Closed 2010-07-05

History

#1 Updated by Scott Roland almost 5 years ago

I agree with this completely.

Problem
In my current setup, new issues can be assigned 3 states. I only want them to be assigned to 1 state: New.

The other two states that Redmine offers as an option are the states that the Author of an Issue is allowed to modify 'New' issues to have. In my case that is Closed and Rejected. It does not make any sense for a new ticket to be created with a status of Closed or Rejected.

Solution
I can understand that some people may want to create a ticket with a status of New or In Progress. Therefore, an extra 'NONE' row is needed in the Workflow settings, as suggested by Mirko.

#2 Updated by Jan Harms over 4 years ago

duplicate of #5816

#3 Updated by Toshi MARUYAMA over 4 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Jan Harms wrote:

duplicate of #5816

Thank you for your pointing.

Also available in: Atom PDF