Feature #10927

Add a filter on the "Issues" page to hide subtasks

Added by Nicolas Jolet about 6 years ago. Updated about 3 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues planning
Target version:-
Resolution:Duplicate

Description

I would find useful to add a filter to hide subtasks in the issue list.
This could help to limit the issue list size, specially if you use subtasks a lot.

This could be also interesting to add a marker that indicates that a task has subtasks.


Related issues

Duplicates Redmine - Feature #9992: Ability to filter issue subtasks in issue form New

History

#1 Updated by Ewan Makepeace about 6 years ago

What you need here would be "AND ParentTask IS NULL" as one of the filter options - currently although you can display the parentTask column, you cant filter on it.

I believe these are related tasks: #10553, #10559
Maybe related: #9992 (could be resolved with AND ParentTask = <someID> filter)

#2 Updated by Mikhail Sviridov over 5 years ago

Yes, it will be great! If I'm goint to set priorities for tasks and set sorting by priority I can't see which tasks are the subtasks and which are not. I think priorities are significant only on the same nesting level not across nesting levels. But now I can set priority in such way:
  • task 1 (high)
  • task 2 (low)
    • subtask 1 (urgent)
    • subtask 2 (critical)
  • task 3 (urgent)
And I have some ambiguity:
I need to work on tasks in such order
  • subtask 2
  • task 3
  • subtask 1
  • task 1
  • priority for task 2 is not significant!
or in such order
  • task 3
  • task 1
  • task 2
    • subtask 2
    • subtask 1

I think the second will be correct. That is priority takes place only for items in group!
May be it depends on used workflow.
If I want to fix some subissue while the parent issue has low priority or is blocked I can simply move this subissue to another parent issue or to move it one level up.

What do you think about it?

#3 Updated by Zube Zahn over 5 years ago

+1

#4 Updated by Daniel Felix over 5 years ago

  • Category set to Issues planning
  • Status changed from New to Closed
  • Resolution set to Duplicate

This one could be closed as duplicate of #9992.

#5 Updated by Bryn Jeffries over 3 years ago

+1 This would be a very useful feature.

Also, this is not a duplicate, although #9992 could be used as a means of achieving this. I suggest this be changed to related to or depends on.

#6 Updated by Toshi MARUYAMA about 3 years ago

Bryn Jeffries wrote:

+1 This would be a very useful feature.

Also, this is not a duplicate, although #9992 could be used as a means of achieving this. I suggest this be changed to related to or depends on.

See #9992#note-8.

Also available in: Atom PDF