Defect #11011

Broken display of subtasks on parent issues

Added by Ewan Makepeace over 5 years ago. Updated over 4 years ago.

Status:ClosedStart date:
Priority:NormalDue date:2013-01-23
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:Cant reproduce Affected version:

Description

I have a two level tree of issues (which normally works very well). However today I see this on my top level parent:

And this on my second level parent:

Notice how both issues are listing the same children! If I look at the children I mostly see this:

However one of the tasks shows this instead:

All the tasks have the correct value in the parent Task field.

top.jpg (99.2 KB) Ewan Makepeace, 2012-05-24 03:26

second.jpg (72.3 KB) Ewan Makepeace, 2012-05-24 03:26

child.jpg (17.2 KB) Ewan Makepeace, 2012-05-24 03:26

weird.jpg (25.5 KB) Ewan Makepeace, 2012-05-24 03:26

top.jpg (99.2 KB) Ewan Makepeace, 2012-05-24 03:27

History

#1 Updated by Ewan Makepeace over 5 years ago

#2 Updated by Ewan Makepeace over 5 years ago

Forgot to mention: Redmine 1.3.0.devel.8638 (MySQL)

#3 Updated by Ewan Makepeace over 5 years ago

This continues to confuse and amaze - unable to edit parent field in some cases. Tried moving task from top level to second level parent and got this exception:

Parent task translation missing: en, activerecord, errors, models, issue, attributes, parent_issue_id, not_a_valid_parent

Have restarted Apache but no change so I dont believe it is an Active Record cache problem?

#4 Updated by Toshi MARUYAMA over 5 years ago

  • Category set to Issues

#5 Updated by Daniel Felix almost 5 years ago

  • Due date set to 2013-01-23
  • Status changed from New to Needs feedback

Can someone confirm this behaviour on the current supported Redmine versions?

#6 Updated by Daniel Felix almost 5 years ago

Cam someone confirm this?
This issue is nearly a year in the tracker. Someone here who can give feedback on the given problem with current releases/trunk?

#7 Updated by Ewan Makepeace almost 5 years ago

While it has not happened again I still have both tasks in my system and they still behave weird behaviour. I am on 2.0.3.devel.10073

#8 Updated by Daniel Felix over 4 years ago

Is there a way for you how to reproduce this? Maybe this one is resolved but the generated data is corrupt. Otherwise we could close this as not reproducible?

#9 Updated by Daniel Felix over 4 years ago

  • Status changed from Needs feedback to Closed
  • Resolution set to Cant reproduce

Closed, as there is no feedback anymore on this and the issue creator can't reproduce it on current releases.

#10 Updated by Maxim Nikolaevich over 4 years ago

i'm not author but probably have same issue.
It was on 1.2.1 redmine
It was on 1.4.4 redmine
And now it on 1.4.7 redmine

I'm not sure, but probably next issue is related with current issue
#6320

#11 Updated by Daniel Felix over 4 years ago

  • Status changed from Closed to Reopened

Can you test this issue with one of the supported Redmine Releases (2.2.4 or 2.3.1)?

#12 Updated by Daniel Felix over 4 years ago

  • Status changed from Reopened to Needs feedback

#13 Updated by Maxim Nikolaevich over 4 years ago

Daniel Felix wrote:

Can you test this issue with one of the supported Redmine Releases (2.2.4 or 2.3.1)?

I'm sorry i have task to update my redmine instance to 2.x but i will do this task later.
At current moment i can not do this.
You can close issue as "can't reproduced" at current moment - i marked my task to check this issue after updating my redmine instance :)
I will update this issue with testing results

#14 Updated by Daniel Felix over 4 years ago

  • Status changed from Needs feedback to Closed

Okay. Thanks for the feedback.

#15 Updated by Ewan Makepeace over 4 years ago

Coincidentally I had someone go into my database and close the broken parent task as it was still completely uneditable even in recent versions. However that does not mean the bug persists - just that once the database gets in an inconsistent state bad things happen.

I never had this happen again.

Also available in: Atom PDF