Defect #11034

TLS configuration documentation for Rails 3

Added by Martin Lindhe over 2 years ago. Updated 12 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Documentation
Target version:2.1.0
Resolution:Fixed Affected version:

Description

Since upgrading to 2.0.0 (also verified today on 2.0.1, and svn trunk) the smtp configuration settings for TLS encryption is somewhat broken, as notified by [1].

If a smtp server is configured with both "tls: true" and "enable_starttls_auto: true", this error occurs when trying to send mail:

An error occurred while sending mail (SSL_connect returned=1 errno=0 state=SSLv2/v3 read server hello A: unknown protocol)

This type of configuration is also the suggested method for configuring gmail in the redmine documentation [2].

As a workaround found by [1], you can remove the "tls: true" part of the configuration, while leaving in "enable_starttls_auto: true". I can also confirm that this workaround works for me, to make gmail & redmine working.

[1]: http://mentalized.net/journal/2012/05/08/rails_3_actionmailer_and_google_apps_for_domains/
[2]: http://www.redmine.org/projects/redmine/wiki/EmailConfiguration

configuration.yml Magnifier (7.14 KB) Rodrigo Macedo, 2013-01-03 13:39

Associated revisions

Revision 10340
Added by Jean-Philippe Lang almost 2 years ago

Fixed TLS configuration in example (#11034).

History

#1 Updated by Daniel Nelson about 2 years ago

Confirmed that using only enable_starttls_auto: true fixes the issue.

#2 Updated by Bruno Medeiros about 2 years ago

Same problem here, and the workaround also worked. Thanks!

#3 Updated by Jean-Philippe Lang almost 2 years ago

  • Subject changed from TLS configuration broken since 2.0 to TLS configuration documentation for Rails 3
  • Category changed from Email notifications to Documentation
  • Status changed from New to Closed
  • Target version set to 2.1.0
  • Resolution set to Fixed

Example in configuration.yml.example fixed in r10340.

#4 Updated by Rodrigo Macedo over 1 year ago

Help Me.

The problem occurrs in enviromento when start Redmine as Window Service.
My OS is Windows XP
Environment:
Redmine version 2.2.0.stable
Ruby version 1.9.2 (i386-mingw32)
Rails version 3.2.9
Environment development
Database adapter Mysql2
Redmine plugins:
no plugin installed

#5 Updated by BTR Naidu over 1 year ago

The suggested workaround did not work for me. Any more ideas?

#6 Updated by Wally Atkins 12 months ago

Agreed with the above comment. I had email notifications working fine in Redmine 1.x but on upgrading to 2.x (actually 2.3.2.stable) the GMail notification email relay is not working. I have tried a bunch of different configuration settings and have not been able to get the right combination. Here is my current config:

default:
  email_delivery:
    delivery_method: :smtp
    smtp_settings:
      enable_starttls_auto: true
      address: "smtp.gmail.com" 
      port: 587
      domain: "smtp.gmail.com" 
      authentication: :plain
      user_name: "MyGMailAccount@gmail.com" 
      password: "areallyhardpassword" 

When I had tls: true in there I would get An error occurred while sending mail (SSL_connect returned=1 errno=0 state=SSLv2/v3 read server hello A: unknown protocol) but without the tls: true I get An error occurred while sending mail (530 5.7.0 Must issue a STARTTLS command first. fy7sm9145396qeb.1 - gsmtp ).

Are there further items that I should check to make sure I have everything required on my system/environment? What is the best way to debug/test this to get down to the nitty gritty details and pinpoint my problem? Any suggestions are greatly appreciated!

Also available in: Atom PDF