Defect #11061

Cannot choose commit versions to view differences in Git/Mercurial repository view

Added by Allanon C. over 5 years ago. Updated over 5 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:SCM
Target version:2.0.3
Resolution:Fixed Affected version:2.0.1

Description

Unable to choose revision# (commits) to view differences in the Repository view when Using Git repository. The radio buttons do not respond to the mouse click or keyboard.

However, if drills down to sub directory of the source file in the repository, it allows us to choose revision# to view differences.

Capture1.jpg - Screenshot (194 KB) Allanon C., 2012-05-30 21:26

Associated revisions

Revision 9832
Added by Etienne Massip over 5 years ago

Added a min-width to revision graph holder style to fix its rendering in Chrome (#11061).

History

#1 Updated by Jean-Philippe Lang over 5 years ago

Could you post a screenshot please?

#2 Updated by Allanon C. over 5 years ago

Here is the screenshot. I cannot click the radio buttons (as indicated by the red arrow) to choose which commits to view the differences. Thanks.

#3 Updated by Etienne Massip over 5 years ago

  • Status changed from New to Confirmed
  • Target version set to Candidate for next minor release

With Alternate theme.

#4 Updated by Etienne Massip over 5 years ago

Has to do with the SVG chart, odd issue.

Triggers with Chrome 19 only for me, neither with IE 9 nor FF 11.

Edit: nor FF 12.

#5 Updated by Toshi MARUYAMA over 5 years ago

  • Subject changed from Cannot choose commit versions to view differences in Git repository view to Cannot choose commit versions to view differences in Git/Mercurial repository view

#6 Updated by Etienne Massip over 5 years ago

Looks like a WebKit rendering issue; could you please try to replace

div.revision-graph { position: absolute;  }

with

div.revision-graph { position: absolute; width: 1px; }

at the top of your public/stylesheets/scm.css?

It seems to solve the issue on my side.

#7 Updated by Daniel Nelson over 5 years ago

I can confirm that adding the "width: 1px;" line to scm.css fixes the problem in Chrome.

#8 Updated by Etienne Massip over 5 years ago

  • Status changed from Confirmed to Resolved
  • Target version changed from Candidate for next minor release to 2.0.3
  • Resolution set to Fixed

Fixed with r9832, merged with r9833 and r9834.

#9 Updated by Jean-Philippe Lang over 5 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF