Feature #11084

Update rails to 3.2.5

Added by John Yani over 5 years ago. Updated over 5 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:Rails support
Target version:2.0.2
Resolution:Fixed

Description

Rails 3.2.5 has been released. Gemfile should be updated

Associated revisions

Revision 9759
Added by Jean-Philippe Lang over 5 years ago

Renamed #changes association to #filechanges (clash with AR::Base.changes that triggers errors with Rails 3.2.5).

Revision 9760
Added by Jean-Philippe Lang over 5 years ago

Renamed #changes association to #ticket_changes.

Revision 9761
Added by Jean-Philippe Lang over 5 years ago

Fixed argument to repository_path that triggers an error with Rails 3.2.5.

Revision 9762
Added by Jean-Philippe Lang over 5 years ago

Test failure due to a regression in Rails 3.2.5.

Revision 9763
Added by Jean-Philippe Lang over 5 years ago

Rails 3.2.5 compatibility.

Revision 9764
Added by Jean-Philippe Lang over 5 years ago

Upgrade to Rails 3.2.5 (#11084).

History

#1 Updated by John Yani over 5 years ago

BTW, it should be

gem 'rails', '~> 3.2.5'

#2 Updated by Jean-Philippe Lang over 5 years ago

  • Tracker changed from Defect to Feature
  • Target version set to 2.0.2

There are failures/errors with Rails 3.2.5, I'm working on it. But we can't just upgrade the Gemfile.
I've also filled a bug for something that looks like a regression: https://github.com/rails/rails/issues/6609

#3 Updated by Jean-Philippe Lang over 5 years ago

  • Category set to Rails support
  • Status changed from New to Closed
  • Assignee set to Jean-Philippe Lang
  • Resolution set to Fixed

2.0-stable upgraded to Rails 3.2.5.

Also available in: Atom PDF