Defect #11172

Custom query with "assignee = none" does not show any issues

Added by Wolfgang Neudorfer over 5 years ago. Updated over 5 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:Invalid Affected version:1.4.2

Description

I want to create a query that shows all issues that have no assignee configured. A custom query with status=open and assignee=none does not show any issues, though.

History

#1 Updated by Etienne Massip over 5 years ago

  • Resolution set to Cant reproduce

Works for me on trunk and on http://m.redmine.org which runs version 1.4.2.

Could be a plugin issue, try with no plugin installed?

Else, what's your DBMS?

#2 Updated by Wolfgang Neudorfer over 5 years ago

I have no plugins installed, DB is MySQL.

#3 Updated by Etienne Massip over 5 years ago

Could you please try to reproduce on http://m.redmine.org?

#4 Updated by Jean-Philippe Lang over 5 years ago

Please read SubmittingBugs first.

#5 Updated by Wolfgang Neudorfer over 5 years ago

Sorry Jean-Philippe:

  • DBMS: MySQL 5.1.61 (running on CentOS 6.2 x64)
  • Ruby: ruby 1.8.7 (2011-06-30 patchlevel 352) [x86_64-linux]
  • Rails: Rails 2.3.14
  • Redmine: 1.4.2
About your application's environment
Ruby version              1.8.7 (x86_64-linux)
RubyGems version          1.3.7
Rack version              1.1.3
Rails version             2.3.14
Active Record version     2.3.14
Active Resource version   2.3.14
Action Mailer version     2.3.14
Active Support version    2.3.14
Application root          /var/www/redmine-1.4.2
Environment               production
Database adapter          mysql
Database schema version   20120301153455

@Etienne: I cannot reproduce this on m.redmine.org.

#6 Updated by Wolfgang Neudorfer over 5 years ago

  • Status changed from New to Resolved

Seems to work now on my installation as well - don't know why though...

#7 Updated by Etienne Massip over 5 years ago

  • Status changed from Resolved to Closed
  • Resolution changed from Cant reproduce to Invalid

Thank you for feedback.

Also available in: Atom PDF