Defect #11296

remove warning in new redmine/extra/svn/reposman.rb

Added by Radek Antoniuk over 7 years ago. Updated over 7 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:SCM extra
Target version:-
Resolution:Wont fix Affected version:

Description

When running reposman to manage repositories

/usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require': iconv will be deprecated in the future, use String#encode instead.

History

#1 Updated by Radek Antoniuk over 7 years ago

redmine version 1.4.4

#2 Updated by Toshi MARUYAMA over 7 years ago

  • Tracker changed from Patch to Defect
  • Status changed from New to Closed
  • Resolution set to Wont fix

iconv needs for Ruby1.8.
We cannot remove it until dropping Ruby1.8 support.

#3 Updated by Radek Antoniuk over 7 years ago

this should not be closed.
I didn't mean removing iconv, but just the warning should be removed :)
with the warning the cron scripts using reposman have to be 2>/dev/null because of the warnings, and this way one cannot see when they fail in fact

Also available in: Atom PDF