Feature #11300

Update issue - form position

Added by # And over 5 years ago. Updated over 1 year ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:Duplicate

Description

I personally use "Reverse chronological order", so latest updates are top located. It is very inconvenient to get a update form at bottom, while latest update in top.

Is this issue but or feature?

form_position.patch Magnifier (1.3 KB) # And, 2012-09-30 22:57


Related issues

Copied to Redmine - Patch #12524: Update issue - form position New

History

#1 Updated by # And over 5 years ago

  • Assignee set to Jean-Philippe Lang

Hey, anyone? =)

#2 Updated by # And about 5 years ago

I resolve it myself. Add, please, code to repository:

  <script type="text/javascript">
    (function(){
      var reverseOrder = <%= User.current.wants_comments_in_reverse_order? %>,
        historyElement = $('history'),
        updateElement = $('update');

      if (reverseOrder && historyElement) {
        // Add br-element at bottom of update for to simulate some margin from journals
          updateElement.insert({ bottom: new Element('br') });

        // Inject before journals
        historyElement.insert({ before: updateElement });
      }
    })();
  </script>

#3 Updated by # And about 5 years ago

Here it code update.

  <script type="text/javascript">
    (function(){
      var reverseOrder = <%= User.current.wants_comments_in_reverse_order? %>,
        historyElement = $('history'),
        updateElement = $('update');

      if (reverseOrder && historyElement) {
        // Add br-element at bottom of update for to simulate some margin from journals
        // and apply css-clear-property to break some long commit lists
          updateElement.insert({ bottom: new Element('br') }).setStyle({ clear: 'both' });

        // Inject before journals
        historyElement.insert({ before: updateElement });
      }
    })();
  </script>

#4 Updated by # And about 5 years ago

Added patch to Redmine 2.1.0.

#5 Updated by # And almost 5 years ago

  • Status changed from New to Resolved

Moved to #12524

#6 Updated by Etienne Massip almost 4 years ago

  • Status changed from Resolved to New
  • Assignee deleted (Jean-Philippe Lang)

I don't think this should be done using JavaScript?

#7 Updated by # And almost 4 years ago

Actually, yes. I just don't know Ruby syntax, that's why I used JS.

#8 Updated by Go MAEDA over 1 year ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Closing as a duplicate of #12524.

Also available in: Atom PDF