Defect #11571

Custom fields of type version not proper handled in receiving e-mails

Added by Klaus G√ľnther over 5 years ago. Updated over 5 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:Email receiving
Target version:2.1.0
Resolution:Fixed Affected version:1.4.1

Description

The value of customer fields of type version not converted to a version id while processing a received e-mail. It must be done like the issue field fixed_version_id.

The code in mail_handler.rb should be something like:

# Returns a Hash of issue custom field values extracted from keywords in the email body
def custom_field_values_from_keywords(customized)
  customized.custom_field_values.inject({}) do |h, v|
    if value = get_keyword(v.custom_field.name, :override => true)
      if v.custom_field.field_format == 'version'
        value = customized.project.shared_versions.named(value).first.try(:id).to_s
      end        
      h[v.custom_field.id.to_s] = value
    end
    h
  end
end

The problem is also in the current trunk.

Associated revisions

Revision 10157
Added by Jean-Philippe Lang over 5 years ago

Fixed: Custom fields of type version not proper handled in receiving e-mails (#11571).

History

#1 Updated by Jean-Philippe Lang over 5 years ago

  • Subject changed from Customer fields of type version not proper handled in receiving e-mails to Custom fields of type version not proper handled in receiving e-mails
  • Status changed from New to Confirmed
  • Target version set to 2.1.0

#2 Updated by Jean-Philippe Lang over 5 years ago

  • Status changed from Confirmed to Closed
  • Assignee set to Jean-Philippe Lang
  • Resolution set to Fixed

Fixed in r10157.

Also available in: Atom PDF