Defect #11735

Weird diffs in wiki pages.

Added by yac yac about 5 years ago. Updated about 5 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Wiki
Target version:-
Resolution:Duplicate Affected version:2.0.3

Description

I have a wiki page which has like 50 lines on revision N. on revision N+1 a few lines were modified and on lines about 2 to 15. But the diff displays lots of content in dark green even though it has not been changed. Also it contains </span> tags as part of the diff. Here I also downloaded the revision as TXT and confirmed there are no changes by using `diff -u` on them.

I tried to reproduce it but was unsuccessfull but i believe i sitll got a weird result. I screencaped it and attached to this issue. On the screencap I believe the "b2" should be marked green as added. and "b" marked red as removed and other lines unhilighted.

I was also unable to find where is documented what those colors mean, so im basing my thoughts on my common sense and guesswork. Light green looks like marks line modification and dark green the actual modification. So clarification on this would be appreciated.

Also after a while of thinking I guess maybe those </span> tags suggests there is really an issue with generating proper diff html.

I don't know how the Prioritues of issues work in these community, so I'm leaving normal but I think this is really big defect as it prevents people keeping up to date with wiki changes.

rm.weird_diffs.jpg (15.5 KB) yac yac, 2012-08-29 22:44


Related issues

Duplicates Redmine - Defect #11209: Wiki diff may generate broken HTML Closed

History

#1 Updated by Jean-Philippe Lang about 5 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Seems to be the same as #11209 which is already fixed in trunk.

Also available in: Atom PDF