Defect #12057

CSS class about issue priority is possibly based on the enumeration ID field instead of position

Added by G N about 7 years ago. Updated about 7 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Resolution:Duplicate Affected version:2.1.2

Description

In the issues list view, the CSS class that is set in each table row regarding the priority of the issue is based on the enumeration ID instead of its position.

Example of issue with "Immediate" priority:

<tr id="issue-706" class="hascontextmenu odd issue status-2 priority-7 created-by-me assigned-to-me">

priority-7 is wrong and should be one of priority-{1,2,3,4,5}.


Related issues

Duplicates Redmine - Defect #11880: Alternate theme colors by issue priority in issue list is... Closed

History

#1 Updated by Etienne Massip about 7 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

See #11880.

Also available in: Atom PDF