Feature #12215

Option to inherit Issue Category list from Parent project to Sub-projects

Added by Douglas Simpson almost 5 years ago. Updated over 3 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:Duplicate

Description

I don't think this is currently possible. (if this is please explain how this is done).

Having a standard "issues category list" user selectable inherit option, for sub-projects would avoid a lot of re-keying and data errors & break-by reporting issues.

This would be useful where project issues / tasks are used for process (or lifecycle) tracking ...

eg.

Inquiry ... Quoted ... Ordered ... Staged ... Shipped

or

Speccing ... Coding ... Testing ... Deployed & Complete ...

or

RNA given ... Item rx'd ... Repair Assessment ... Quoted ...
PO Rx'd ... In repair ... Returned complete


Related issues

Duplicates Redmine - Feature #5358: Share Issues Categories for sub-projects New 2010-04-20

History

#1 Updated by Joshua DeClercq almost 5 years ago

The route most people seem to be taking for inheritance is copying a project, from the Administration -> Projects page. If you're frequently creating projects of certain types, it's helpful to build (or designate from existing) a template project to serve this purpose.

#2 Updated by Mikołaj Milej over 4 years ago

It looks like that it was fixed some time ago #1653 but now is broken again... When you change issue project the category is lost even when names match.
What's more, on version summary when you Show version details in road map and then in "Issues by" you select Category there appears the same categories multiple times:
  • project1
    • category1 (id 1)
  • sub project of project1
    • category1 (id 5)

In result you'll get category1 twice if you selected the same version for issues.

#3 Updated by Daniel Küppers almost 4 years ago

Duplicate of #5358

#4 Updated by Toshi MARUYAMA over 3 years ago

  • Status changed from New to Closed
  • Assignee deleted (Jean-Philippe Lang)
  • Resolution set to Duplicate

Daniel Küppers wrote:

Duplicate of #5358

Thank you for your pointing.

#5 Updated by Toshi MARUYAMA over 3 years ago

  • Duplicates Feature #5358: Share Issues Categories for sub-projects added

Also available in: Atom PDF