Defect #12243

Ordering forum replies by last reply date is broken

Added by Intrad Acebo about 5 years ago. Updated over 4 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:Forums
Target version:2.2.4
Resolution:Fixed Affected version:

Description

Would be very nice allow to sort by last reply date in forums. I think is not possible now.

Something like this:

Thanks!!

Screen Shot 2012-12-05 at 00.27.12.png (48.4 KB) Jean-Claude Wippler, 2012-12-05 00:29


Related issues

Duplicated by Redmine - Defect #13669: Sorting forum message list by "Last message" (="updated_o... Closed

Associated revisions

Revision 11424
Added by Jean-Philippe Lang almost 5 years ago

Fixed that messages are not sorted by last reply (#12243).

Revision 11594
Added by Jean-Philippe Lang over 4 years ago

Backported r11424 from trunk (#12243).

History

#1 Updated by Toshi MARUYAMA about 5 years ago

  • Category set to Forums

#2 Updated by Jean-Claude Wippler almost 5 years ago

Yes. I had in fact expected that sort on last message would do this, but the sort order doesn't look right - this is with 2.2.0-dev, i.e. trunk.

See attached example. There was a post "New & Updated", I added 5 new posts, and then added a reply to that "New & Updated" post. Had expected to see that N & E post to rise to the top.

#3 Updated by Anonymous almost 5 years ago

I'm voting this one up. The Redmine Forums don't look like traditional forums. The last reply should be the topmost.

#4 Updated by Jean-Claude Wippler almost 5 years ago

See this forum as example - a few people are getting confused as to what is most recent:
http://jeelabs.net/projects/cafe/boards/6?sort=updated_on%3Adesc

I track the forum by email, and get everything in time-order that way, but it would be nice if you could go to the forum page and somehow see what messages you haven't read since the last time you visited. Doesn't have to be fancy (per-user highlighting), but a clear date order from top to bottom would help.

#5 Updated by Jean-Claude Wippler almost 5 years ago

Sorry to keep posting here - but the forum posts are really not sorting as expected. When sorting on "Last message", the list gets sorted on "Created". See link in my previous post for an example. This is running the latest code, pulled from GitHub minutes ago:

Environment:
Redmine version 2.2.2.devel
Ruby version 1.8.7 (i486-linux)
Rails version 3.2.11
Environment production
Database adapter MySQL

#6 Updated by Jean-Claude Wippler almost 5 years ago

Any news on this? I can't seem to find any logic to how forum posts are ordered when clicking on the "Last message" header.

#7 Updated by Jean-Claude Wippler almost 5 years ago

Ping? Sorry for making a nuisance of myself, but could someone please reply and explain or address this issue?

#8 Updated by Jean-Philippe Lang almost 5 years ago

  • Subject changed from Order forum replies by last reply date to Ordering forum replies by last reply date is broken
  • Status changed from New to Resolved
  • Assignee set to Jean-Philippe Lang
  • Target version set to 2.2.4
  • Resolution set to Fixed

The updated_on column is no longer updated when adding a reply hence the sort was broken. It's now fixed in r11424. Thanks for pointing this out.

#9 Updated by Toshi MARUYAMA almost 5 years ago

  • Tracker changed from Feature to Defect

#10 Updated by Jean-Claude Wippler almost 5 years ago

Thank you! Confirmed to work perfectly now - http://jeelabs.net/projects/cafe/boards/6

#11 Updated by Jean-Philippe Lang over 4 years ago

  • Status changed from Resolved to Closed

Thanks for the feedback.

Also available in: Atom PDF