Defect #12642

Issue preview link not working after recent changes in config/routes.rb

Added by Egidijus Zideckas almost 5 years ago. Updated almost 5 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:Fixed Affected version:

Description

Recent commit broken preview link: Specifies HTTP methods for all routes. https://github.com/edavis10/redmine/commit/2ebcc6d9601f86334119bd17a8eb65851d374f84

Error in log file:

Started PUT "/issues/preview/edit/5?project_id=test1" for 127.0.0.1 at Wed Dec 19 09:48:52 +0100 2012

ActionController::RoutingError (No route matches [PUT] "/issues/preview/edit/5"):
  actionpack (3.2.9) lib/action_dispatch/middleware/debug_exceptions.rb:21:in `call'
  actionpack (3.2.9) lib/action_dispatch/middleware/show_exceptions.rb:56:in `call'
  railties (3.2.9) lib/rails/rack/logger.rb:32:in `call_app'
  railties (3.2.9) lib/rails/rack/logger.rb:16:in `call'
  activesupport (3.2.9) lib/active_support/tagged_logging.rb:22:in `tagged'
  railties (3.2.9) lib/rails/rack/logger.rb:16:in `call'
  actionpack (3.2.9) lib/action_dispatch/middleware/request_id.rb:22:in `call'
  rack (1.4.1) lib/rack/methodoverride.rb:21:in `call'
  rack (1.4.1) lib/rack/runtime.rb:17:in `call'
  activesupport (3.2.9) lib/active_support/cache/strategy/local_cache.rb:72:in `call'
  rack (1.4.1) lib/rack/lock.rb:15:in `call'
  actionpack (3.2.9) lib/action_dispatch/middleware/static.rb:62:in `call'
  railties (3.2.9) lib/rails/engine.rb:479:in `call'
  railties (3.2.9) lib/rails/application.rb:223:in `call'
  rack (1.4.1) lib/rack/content_length.rb:14:in `call'
  railties (3.2.9) lib/rails/rack/log_tailer.rb:17:in `call'
  rack (1.4.1) lib/rack/handler/webrick.rb:59:in `service'
  /usr/lib/ruby/1.8/webrick/httpserver.rb:104:in `service'
  /usr/lib/ruby/1.8/webrick/httpserver.rb:65:in `run'
  /usr/lib/ruby/1.8/webrick/server.rb:173:in `start_thread'
  /usr/lib/ruby/1.8/webrick/server.rb:162:in `start'
  /usr/lib/ruby/1.8/webrick/server.rb:162:in `start_thread'
  /usr/lib/ruby/1.8/webrick/server.rb:95:in `start'
  /usr/lib/ruby/1.8/webrick/server.rb:92:in `each'
  /usr/lib/ruby/1.8/webrick/server.rb:92:in `start'
  /usr/lib/ruby/1.8/webrick/server.rb:23:in `start'
  /usr/lib/ruby/1.8/webrick/server.rb:82:in `start'
  rack (1.4.1) lib/rack/handler/webrick.rb:13:in `run'
  rack (1.4.1) lib/rack/server.rb:265:in `start'
  railties (3.2.9) lib/rails/commands/server.rb:70:in `start'
  railties (3.2.9) lib/rails/commands.rb:55
  railties (3.2.9) lib/rails/commands.rb:50:in `tap'
  railties (3.2.9) lib/rails/commands.rb:50
  /script/rails:6:in `require'
  /script/rails:6
  ruby-debug-ide (0.4.9) lib/ruby-debug-ide.rb:109:in `debug_load'
  ruby-debug-ide (0.4.9) lib/ruby-debug-ide.rb:109:in `debug_program'
  ruby-debug-ide (0.4.9) bin/rdebug-ide:87
  /usr/local/bin/rdebug-ide:19:in `load'
  /usr/local/bin/rdebug-ide:19

issue_preview_fix.diff Magnifier (818 Bytes) Egidijus Zideckas, 2012-12-19 09:51


Related issues

Duplicated by Redmine - Defect #12751: The Preview link on the bottom doesn't work in the issue'... Closed

Associated revisions

Revision 11133
Added by Jean-Philippe Lang almost 5 years ago

Fixed that previews are broken by r10957 (#12642).

History

#1 Updated by Egidijus Zideckas almost 5 years ago

Patch fixing problem

#2 Updated by Etienne Massip almost 5 years ago

  • Status changed from New to Confirmed
  • Target version set to 2.3.0

We are aware of this one, I guess it does not only affect issue preview but other previews too.

I'd like to remove the :get method too and to include non-regression tests using e.g. Capybara because we break JS too often and there is more and more client code included in Redmine source.

#3 Updated by Toshi MARUYAMA almost 5 years ago

Etienne Massip wrote:

We are aware of this one, I guess it does not only affect issue preview but other previews too.

I'd like to remove the :get method too and to include non-regression tests using e.g. Capybara because we break JS too often and there is more and more client code included in Redmine source.

Include capybara for integration tests
https://www.chiliproject.org/issues/747

#4 Updated by Etienne Massip almost 5 years ago

Toshi MARUYAMA wrote:

Include capybara for integration tests
https://www.chiliproject.org/issues/747

Thanks for pointing this out Toshi, although there haven't been that much tests produced afterwards alas :(

I tried and failed, if you have an idea I need help, see my bottle Need help making Capybara + selenium with Ajax working :)

#5 Updated by Etienne Massip almost 5 years ago

  • Status changed from Confirmed to Closed
  • Target version deleted (2.3.0)
  • Resolution set to Fixed

Also available in: Atom PDF