Patch #12937

mail_handler patch

Added by Dinu Marina over 6 years ago. Updated 8 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Email receiving
Target version:-

Description

I submit this rather elementary patch that fixes 2 issues in mail_handler.rb:

1) If Project: tag in email cannot be honored (missing project), rather than failing, the issue is assigned to the default project defined in settings

2) Preserve outlook style email addresses in the form <user@domain>. Previously they were stripped as html tags because the <> brackets. The regexp is rather liberal but I find, well suited for the job.

Patch is against Redmine 2.0

mail_handler.patch Magnifier (1012 Bytes) Dinu Marina, 2013-01-21 23:59


Related issues

Related to Redmine - Feature #16962: Better handle html-only emails Closed
Related to Redmine - Defect #14491: MailHandler: Unable to determine target project (when all... Closed

History

#1 Updated by Go MAEDA 8 months ago

  • Status changed from New to Closed

Dinu Marina wrote:

1) If Project: tag in email cannot be honored (missing project), rather than failing, the issue is assigned to the default project defined in settings

Fixed in r12067 for Redmine 2.6.0.

2) Preserve outlook style email addresses in the form <user@domain>. Previously they were stripped as html tags because the <> brackets. The regexp is rather liberal but I find, well suited for the job.

Fixed by #16962 for Redmine 3.1.0.

#2 Updated by Go MAEDA 8 months ago

#3 Updated by Go MAEDA 8 months ago

  • Related to Defect #14491: MailHandler: Unable to determine target project (when allow_override=project and project=unassigned is used) added

Also available in: Atom PDF