Defect #13017

onbeforeunload lost when fields loaded via AJAX

Added by Matt Rogowski almost 7 years ago. Updated over 6 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:Invalid Affected version:2.2.0

Description

If you enter some text and try and reload the page or go back, you will get the onbeforeunload even show you a warning asking if you want to leave the page. If you change a field that then has to check the requirements of other fields, i.e. Tracker or Status, the AJAX call will reload the fields as expected, but the onbeforeunload is then lost, and reloading the page or clicking back will go through with no warning.

History

#1 Updated by Etienne Massip over 6 years ago

  • Status changed from New to Needs feedback
  • Assignee set to Matt Rogowski
  • Resolution set to Cant reproduce

I can't reproduce with FF 22, what browser did you test with and could you make a new try on http://m.redmine.org?

#2 Updated by Matt Rogowski over 6 years ago

Seems this may have since been fixed as I can't reproduce it anymore either :)

#3 Updated by Etienne Massip over 6 years ago

  • Status changed from Needs feedback to Closed
  • Assignee deleted (Matt Rogowski)
  • Resolution changed from Cant reproduce to Invalid

Thanks for your feedback, please reopen the issue if you reproduce it.

Also available in: Atom PDF