Defect #13036

auto generated comment "Applied in changeset xxx" is not link to commit

Added by Bảo Gia over 4 years ago. Updated over 2 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:SCM
Target version:-
Resolution:Duplicate Affected version:2.2.2

Description

It should be:
"Applied in changeset commit:repoid|hash."
Not:
"Applied in changeset repoid|commit:hash."

cs.patch Magnifier - Fix repo identifier in commit link (1.48 KB) A B, 2013-03-17 06:51

cs_mod.patch Magnifier - Fix repo identifier in commit link patch update (1.48 KB) Viktor Berke, 2013-11-22 15:27


Related issues

Related to Redmine - Defect #12685: Commit message generates invalid link when repository has... Closed
Duplicates Redmine - Defect #13544: Commit reference: autogenerated issue note has wrong comm... Closed

History

#1 Updated by Dietmar H over 4 years ago

I can confirm this.
I guess the extended syntax is intentional, because now more then 1 repository per project are allowed. With svn repos, that means the repo must be included in the commit macro in order to uniquely identify the commit.
However the macro isn't expanded to a link if it contains the repo.

Redmine version here: 2.2.2.stable

#2 Updated by Dietmar H over 4 years ago

seems to be a duplicate of #13005

#3 Updated by Bảo Gia over 4 years ago

Dietmar Hofer wrote:

seems to be a duplicate of #13005

No. #13005 is abount repoid "contains underscores"

#4 Updated by Bảo Gia over 4 years ago

Dietmar Hofer wrote:

I guess the extended syntax is intentional, because now more then 1 repository per project are allowed. With svn repos, that means the repo must be included in the commit macro in order to uniquely identify the commit.

No. This is a bug, not "intentional".
It should be "commit:repoid|hash" (have repoid => can support >1 repo per project)

#5 Updated by A B over 4 years ago

Attached is a patch to fix this. Unlike the patch in #12685 this works for both hash-based and non-hash based (e.g. subversion) revisions, and includes a unit test for the hash-based case (the non-hash based case already has a test).

#6 Updated by Daniel Felix over 4 years ago

Thanks for providing a patch!

I would like to test it but I can't. I'm currently at hospital. Maybe someone can check this. Maybe this one could find its way in 2.2.4/2.3 in a fast pace if it could be evaluated! :-)

#7 Updated by Viktor Berke almost 4 years ago

Hi, I can confirm this bug. I've tested both patches (i.e. this one and the one from #12685) on Redmine 2.4.0, they both work. Please merge this.

#8 Updated by Viktor Berke almost 4 years ago

Though I suggest some logical cleanup, i.e. | is not part of the repo id. The very slightly modified patch is attached.

#9 Updated by Toshi MARUYAMA over 2 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Fixed by #13544.

#10 Updated by Toshi MARUYAMA over 2 years ago

  • Duplicates Defect #13544: Commit reference: autogenerated issue note has wrong commit link syntax in multi-repo or cross-project context added

Also available in: Atom PDF