Defect #13273

Making a copied ticket a child of the copying ticket results in an infinite loop at server side

Added by Toru Haraguchi over 4 years ago. Updated over 4 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:Invalid Affected version:2.2.2

Description

Need either of...
  • Prevention on the form field
  • Change in querying strategy against SQL backend

History

#1 Updated by Toru Haraguchi over 4 years ago

How to reproduce
  • Open a ticket "A"
  • Click on "copy" link
  • enter the ID of "A" into "parent ID" field on the form
  • Click "send" button

#2 Updated by Jean-Philippe Lang over 4 years ago

  • Resolution set to Cant reproduce

Works for me. The child issue is created with its parent. Any plugins?

#3 Updated by Toshi MARUYAMA over 4 years ago

  • Status changed from New to Needs feedback

#4 Updated by Toru Haraguchi over 4 years ago

Many plugins, but all in-house.
Will report what addition caused it, after investigating with outsource company.

#5 Updated by Toru Haraguchi over 4 years ago

Firstly, "How to reproduce" was missing one important condition.

  • Open a ticket "A" with one or more child ticket
  • Click on "copy" link
  • enter the ID of "A" into "parent ID" field on the form
  • Click "send" button

Original Redmine 2.2.2 had different symptom, but no infinite loop .
The infinite loop was shown only after the patch trunk-r11262.diff is aplied.

Will report original Redmine 2.2.2 symptom on a separate ticket.

#6 Updated by Jean-Philippe Lang over 4 years ago

Tested, works for me with current trunk.

#7 Updated by Toshi MARUYAMA over 4 years ago

  • Status changed from Needs feedback to Closed
  • Resolution changed from Cant reproduce to Invalid

Toru Haraguchi wrote:

The infinite loop was shown only after the patch trunk-r11262.diff is aplied.

trunk-r11262.diff is in #1005#note-30.

Also available in: Atom PDF