Defect #13575

Graphic characters not exported

Added by Ivan Cenov over 4 years ago. Updated almost 2 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:PDF export
Target version:-
Resolution:Fixed Affected version:2.3.0

Description

Here is a sample how the graphic characters are not exported well. This is a sample state machine diagram:


          ┌───────────────┐        evLowTemp, evHighTemp           ┌───────────────┐
          │  sP1_BADTEMP  ├───────────────────◄────────────────────┤ sP1_LOWVOLTAGE│
          └───────┬───────┘                (P1a4)                  └───────┬───────┘
                  ▲                                                        ▲
                  │ evLowTemp, evHighTemp                                  │ evLowVoltage
                  │       (P1a4)                                           │    (P1a5)
                  │                    ┌───────────────┐                   │
                  └────────────────────┤   sP1_IDLE    ├───────────────────┘
                                       └───────────────┘               

All versions are affected. Try to export to PDF. You will see squares instead of lines and arrows in the exported PDF file.

jkjkjk-306.pdf - Redmine 3.2 sample pdf (128 KB) Jun NAITOH, 2015-12-10 12:42

Graphic_characters_pdf_redmine320.png (40.5 KB) Jun NAITOH, 2015-12-10 12:44


Related issues

Related to Redmine - Defect #10681: Export to Persian PDF problem Closed
Related to Redmine - Defect #13781: CJK(Chinese/Japanese/Korean) characters are not shown in ... Closed
Related to Redmine - Defect #20499: Bangla charater of PDF New

History

#1 Updated by Filou Centrinov over 4 years ago

Related with #10681. Same problem with persian or chinese characters.

#2 Updated by Ivan Cenov over 4 years ago

It seems the problem is the font that is used for rendering the content. There is a set of fonts that are used and they are in source:/trunk/lib/plugins/rfpdf/lib/fonts Probably these fonts have no defined graphic characters in them.

Font selection is made in source:/trunk/lib/redmine/export/pdf.rb#L40

I suspect that the missing characters should be added to the fonts. However I do not know how ... :(

#3 Updated by Filou Centrinov over 4 years ago

The font (freesans) can be easily updated from http://sourceforge.net/projects/tcpdf/files/

But you will still have the problem with displaying your graphic, because pre-Tags are not considered yet and so it's not displayed in mono font.

#4 Updated by Filou Centrinov over 4 years ago

How ever, I regret an font file update, because the font file are much bigger than before. Only an update for the main font (FreeSans) would increase the pdf file size about 220 kb. ... and not solving your problem.

#5 Updated by Ivan Cenov over 4 years ago

I use pre tags because they preserve character width. The following is without pre-tags:

┌───────────────┐ evLowTemp, evHighTemp ┌───────────────┐
│ sP1_BADTEMP ├───────────────────◄────────────────────┤ sP1_LOWVOLTAGE│
└───────┬───────┘ (P1a4) └───────┬───────┘

The size of PDF file is not so important.

#6 Updated by Filou Centrinov over 4 years ago

Ivan Cenov wrote:

I use pre tags because they preserve character width. The following is without pre-tags:

┌───────────────┐ evLowTemp, evHighTemp ┌───────────────┐
│ sP1_BADTEMP ├───────────────────◄────────────────────┤ sP1_LOWVOLTAGE│
└───────┬───────┘ (P1a4) └───────┬───────┘

This is like you will see it in the pdf after the font update. I think this won't satisfy you.

#7 Updated by Toshi MARUYAMA about 2 years ago

#8 Updated by Jun NAITOH almost 2 years ago

I think this problem was fixed by Redmine 3.2(rbpdf 1.19.0).

This is a sample in English locale (en.yml).

#9 Updated by Toshi MARUYAMA almost 2 years ago

  • Status changed from New to Closed
  • Resolution set to Fixed

Jun NAITOH wrote:

I think this problem was fixed by Redmine 3.2(rbpdf 1.19.0).

Thank you.

Also available in: Atom PDF