Defect #13840

Style issues by priority position, not id

Added by Rocco Stanzione over 4 years ago. Updated about 4 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:Duplicate Affected version:

Description

This probably gets overlooked because people create priorities in the right order the first time, or use themes that leverage position_name, so it always looks right. If you reorder them, themes that style according to classes like priority-n have a bad time. In the IssuePriority model can we change this method definition like so?

  def css_classes
    "priority-#{position} priority-#{position_name}" 
  end

I'd submit a patch, but... for bonus points could we maybe move that process to github, where I can easily fork and submit pull requests?


Related issues

Duplicates Redmine - Defect #11880: Alternate theme colors by issue priority in issue list is... Closed

History

#1 Updated by Mischa The Evil about 4 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Rocco Stanzione wrote:

... If you reorder them, themes that style according to classes like priority-n have a bad time. In the IssuePriority model can we change this method definition like so? ...

See issue #2071#note-7 (note-7).

This is a duplicate of #11880. The rationale of the change is outlined best in #2071.

#2 Updated by Mischa The Evil about 4 years ago

  • Duplicates Defect #11880: Alternate theme colors by issue priority in issue list is wrong added

Also available in: Atom PDF