Feature #13843

Redmine API: can wiki pages contain uploads

Added by Fabrice Brito over 4 years ago. Updated almost 2 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:REST API
Target version:-
Resolution:Duplicate

Description

hi!

I'm trying to add attachments to a wiki page created via the Redmine API.

Is the XML below supported?

<?xml version="1.0"?>
<wiki_page>
  <text>Some text
</text>
  <comments></comments>
<uploads type=array>
<upload>
<token>538.587d2a7796df47552dd720c83e952a2b</token>
<filename>application.1.xml</filename>
<content_type>text/plain</content_type>
</upload>
<upload>
<token>539.0f92777604a4ea3fa0cde1208042f641</token>
<filename>application.2.xml</filename>
<content_type>text/plain</content_type>
</upload>
</uploads>
</wiki_page>

Related issues

Related to Redmine - Feature #13853: Is it possible to sponsor the implementation of features? Closed
Duplicates Redmine - Feature #14830: REST API : Add support for attaching file to Wiki pages Closed

History

#1 Updated by Emmanuel Mathot over 4 years ago

+1
I tried in json but no luck

#2 Updated by Go MAEDA almost 2 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Closing as duplicate of #14830.

#3 Updated by Go MAEDA almost 2 years ago

  • Duplicates Feature #14830: REST API : Add support for attaching file to Wiki pages added

Also available in: Atom PDF