Defect #14151

Grammer problem with German x_days

Added by Filou Centrinov over 5 years ago. Updated almost 4 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Translations
Target version:3.0.0
Resolution: Affected version:

Description

There is a grammer problem for the german translation with label "x_days:other:" used in the admin settings (app/views/settings/_authentication.html.erb). Correct would be "{count} Tage", not "{count} Tagen".

The translation would be like here: https://github.com/svenfuchs/rails-i18n/blob/master/rails/locale/de.yml#LC81

The problem is that in other context the actutal translation would be correct. So for example "Von NAME vor etwa 3 Tagen aktualisiert" (Updated by NAME about 3 days ago) is correct.

14151.diff Magnifier (1 KB) Jan from Planio www.plan.io, 2014-11-04 13:13


Related issues

Related to Redmine - Patch #14148: Double translation: label_f_hours vs. x_hours Reopened

Associated revisions

Revision 11907
Added by Toshi MARUYAMA over 5 years ago

German "x_days" translation changed by Filou Centrinov (#14151)

Revision 11910
Added by Toshi MARUYAMA over 5 years ago

back out r11907 (#14151)

German "x_days" translation changed by Filou Centrinov.

Revision 13581
Added by Toshi MARUYAMA almost 4 years ago

German "label_roadmap_overdue" and "setting_autologin" translation changed by Jan from Planio www.plan.io (#14151)

History

#1 Updated by Toshi MARUYAMA over 5 years ago

  • Subject changed from Grammer problem with x_days to Grammer problem with German x_days
  • Target version set to 2.4.0

#2 Updated by Filou Centrinov over 5 years ago

Hello Toshi,

your patch is not a solution of the problem.
On one hand, when we have a list of days, like in the administration settings, it should be "1 Tag, 2 Tage, 3 Tage, ..." in lists. But on the other hand "Von .. vor etwa 3 Tagen aktualisiert" (Updated by .. about 3 days ago) is correct, too.

As long we have no complete solution I would keep Tagen, because "Von .. vor etwa 3 Tagen aktualisiert" is used is issues and viewed quite often.

#3 Updated by Filou Centrinov over 5 years ago

This problem is related with #14148, because we need an additional label to solve this issue. This label would be something like "label_f_days" we use for lists or no phrases.

#4 Updated by Toshi MARUYAMA over 5 years ago

  • Target version deleted (2.4.0)

#5 Updated by Jan from Planio www.plan.io almost 4 years ago

I think, in general it's not correct, to use "Tagen", "Monaten", etc. as the regular x_days:other:, x_months:other: translations, because they're "Akkusativ" (a grammatical case). Correct would be "Tage", "Monate", etc. which is Nominativ, i.e. the "regular" case.

However, since they are most prominently used in phrases where the Akkusativ should be used (e.g. "vor X Tagen" - "X days ago"), the practical approach would be to keep things as they are and try to rework the few phrases/translations that don't use Akkusativ yet. So, I would propose:

-setting_autologin: Automatische Anmeldung
+setting_autologin: Automatische Anmeldung läuft ab nach
-label_roadmap_overdue: "%{value} verspätet" 
+label_roadmap_overdue: "seit %{value} verspätet"

Please find a diff attached. Not sure if I missed any other translations. Maybe the other german-speaking contributors could weigh in on this? (I just made them watchers...)

#6 Updated by Jan Niggemann (redmine.org team member) almost 4 years ago

+1 --> I second Jans proposal

#7 Updated by Toshi MARUYAMA almost 4 years ago

  • Target version set to 3.0.0

#8 Updated by Jean-Philippe Lang almost 4 years ago

  • Status changed from New to Closed

Also available in: Atom PDF