Defect #14239

Error 403 when trying to edit custom query

Added by Filou Centrinov about 5 years ago. Updated 3 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:Fixed Affected version:2.3.1

Description

I get an error 403 when I try to edit a custom query. How to reproduce:

1) login as admin
2) create a custom query
3) query settings: "Public" + "For all projects"
4) save query

5) login as non admin user and manager of a project
6) edit the custom query. You will get an error 403 with warning "You are not authorized to access this page."

Tested on Redmine 2.3.1.stable.11941, no plugins.


Related issues

Related to Redmine - Defect #17669: Non admin users can't modify public queries for all project Closed
Related to Redmine - Defect #28264: Global and public custom queries are shown as editable to... Closed

History

#1 Updated by tomoaki maeda almost 4 years ago

Its reproducing on 2.5.1.stable

#2 Updated by Michael Esemplare almost 4 years ago

Duplicate of #17669.

#3 Updated by Toshi MARUYAMA almost 4 years ago

  • Related to Defect #17669: Non admin users can't modify public queries for all project added

#4 Updated by Marius BALTEANU 5 months ago

  • Related to Defect #28264: Global and public custom queries are shown as editable to non administrators in projects added

#5 Updated by Marius BALTEANU 3 months ago

  • Status changed from New to Closed
  • Resolution set to Fixed

I'm considering this defect as fixed because the Edit/Delete buttons are no longer available to users without required permissions (fixed in #28264).

Also available in: Atom PDF