Defect #14466

Wrap long issue fields in issue pdf header

Added by Filou Centrinov almost 5 years ago. Updated over 3 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:PDF export
Target version:2.6.0
Resolution: Affected version:

Description

This patch wraps long issue fields in the issue pdf header. This works for all issue fields in the header (also for long custum fields).

Before:

After:

issue_nobreak.png (9.23 KB) Filou Centrinov, 2013-07-16 00:07

issue_withbreak.png (9.64 KB) Filou Centrinov, 2013-07-16 00:07

pdf.rb.patch Magnifier (2.71 KB) Filou Centrinov, 2013-07-16 00:11


Related issues

Related to Redmine - Defect #11839: Text overlay when exporting issues to pdf files Confirmed
Related to Redmine - Defect #16335: exporting issue as pdf --> text out of box Closed

History

#1 Updated by Etienne Massip almost 5 years ago

  • Target version set to Candidate for next major release

#2 Updated by Daniele Pedroni over 4 years ago

Great, +1!

This looks like a simple and straight-forward solution for a really annoying problem, no way to introduce it for 2.4.0 release?
It would be really appreciated.

#3 Updated by Mischa The Evil over 4 years ago

  • Related to Defect #11839: Text overlay when exporting issues to pdf files added

#4 Updated by Toshi MARUYAMA about 4 years ago

  • Related to Defect #16335: exporting issue as pdf --> text out of box added

#5 Updated by Daniel Ritz almost 4 years ago

+1

Same problem for me too. The patch solves the problem nicely. Thanks.

#6 Updated by Toshi MARUYAMA over 3 years ago

  • Tracker changed from Patch to Defect
  • Status changed from New to Closed
  • Target version changed from Candidate for next major release to 2.6.0

Fixed by #17570.

Also available in: Atom PDF