Defect #14646

Migrating from Trac, users are not imported

Added by Jack Reacher over 4 years ago. Updated over 4 years ago.

Status:ClosedStart date:
Priority:UrgentDue date:
Assignee:-% Done:

0%

Category:Importers
Target version:-
Resolution:Duplicate Affected version:2.3.2

Description

The official Redmine from Track migrate plugin should import users (as wrote down here: RedmineMigrate ), but it does not.

In Redmine I see on all ticket that Redmine Admin is the reporter. And reassign 1000 open ticket is a bit painfull. :(

Environment:
Redmine version 2.3.2.stable
Ruby version 1.9.3-p448 (2013-06-27) [i386-mingw32]
Rails version 3.2.13
Environment production
Database adapter Mysql2
Rails Version: Rails 3.2.13
Database: MySQL 5.6.13


Related issues

Duplicates Redmine - Defect #14590: migrate_from_trac.rake does not import Trac users, uses t... Closed

History

#1 Updated by Craig Rodrigues over 4 years ago

This is a duplicate of #14590 which I reported.

I submitted a whole bunch of fixes recently to fix migrate_from_trac.rake .

Until the Redmine developers incorporate the patches, you should get the version from:

https://github.com/rodrigc/redmine/blob/master/lib/tasks/migrate_from_trac.rake

and replace that file in your tree, and re-run the import.

#2 Updated by Mischa The Evil over 4 years ago

  • Status changed from New to Needs feedback

Craig Rodrigues wrote:

This is a duplicate of #14590 which I reported.

Jack, can you confirm if this is indeed a duplicate by applying the patch of Craig posted in #14590 and trying the import again?

#3 Updated by Jack Reacher over 4 years ago

Yes, I confirm.

#4 Updated by Etienne Massip over 4 years ago

  • Related to Defect #14590: migrate_from_trac.rake does not import Trac users, uses too short password added

#5 Updated by Etienne Massip over 4 years ago

  • Related to deleted (Defect #14590: migrate_from_trac.rake does not import Trac users, uses too short password)

#6 Updated by Etienne Massip over 4 years ago

  • Duplicates Defect #14590: migrate_from_trac.rake does not import Trac users, uses too short password added

#7 Updated by Etienne Massip over 4 years ago

  • Status changed from Needs feedback to Closed
  • Resolution set to Duplicate

Also available in: Atom PDF