Defect #14791

Can't move spent time between projects

Added by Anton Nepomnyaschih about 4 years ago. Updated over 3 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Time tracking
Target version:-
Resolution: Affected version:

Description

Steps to reproduce:

  1. Log spent time at issue #1 at project "ProjectA".
  2. Edit the spent time log: change issue to #2 (which is in ProjectB).

Expected result:

The time log is moved to issue #2 (which is in another project - ProjectB).

Actual result:

"Invalid issue" message.

History

#1 Updated by Thomas Godard about 4 years ago

Reproduced on Redmine 2.3.1

#2 Updated by Toshi MARUYAMA about 4 years ago

  • Category set to Time tracking

#3 Updated by Systems Administration over 3 years ago

Possibly related to (or duplicate of) #588 ?

#4 Updated by Anton Nepomnyaschih over 3 years ago

I think so. It would be helpful to add more detailed error message, not only "Invalid issue", but for example "Timelog can't be moved between projects".

#5 Updated by Anton Nepomnyaschih over 3 years ago

  • Status changed from New to Resolved

#6 Updated by Jan Niggemann (redmine.org team member) over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF