Defect #14883

Update activerecord-jdbc-adapter

Added by Daniel Morgan about 4 years ago. Updated about 4 years ago.

Status:ClosedStart date:
Priority:HighDue date:
Assignee:-% Done:

0%

Category:Gems support
Target version:2.3.4
Resolution:Fixed Affected version:

Description

When using redmine under JRuby, the bundler installs activerecord-jdbc-adapter 1.2.5 specified by the Gemfile.
There are some serious issues with this version when using JRuby in Ruby 1.9 mode such as:
https://github.com/jruby/activerecord-jdbc-adapter/issues/229

Can redmine be updated to use a more recent gem version?
(The above issue has been fixed in 1.2.6)


Related issues

Related to Redmine - Defect #14656: JRuby: Encoding error when creating issues Closed

Associated revisions

Revision 12172
Added by Toshi MARUYAMA about 4 years ago

Gemfile: update jdbc adapter version above 1.2.6 (#14883)

Revision 12174
Added by Toshi MARUYAMA about 4 years ago

Merged r12172 from trunk to 2.3-stable (#14883)

Gemfile: update jdbc adapter version above 1.2.6.

Revision 12175
Added by Toshi MARUYAMA about 4 years ago

Gemfile: update jdbc adapter version above 1.3.0 (#14883)

Revision 12179
Added by Toshi MARUYAMA about 4 years ago

revert r12175 (#14883)

revert jdbc adapter version to above 1.2.6
due to test failure by "stack level too deep".

History

#1 Updated by Toshi MARUYAMA about 4 years ago

  • Related to Defect #14656: JRuby: Encoding error when creating issues added

#2 Updated by Toshi MARUYAMA about 4 years ago

  • Target version set to 2.3.4

#3 Updated by Toshi MARUYAMA about 4 years ago

  • Tracker changed from Feature to Defect

#4 Updated by Toshi MARUYAMA about 4 years ago

  • Status changed from New to Closed
  • Resolution set to Fixed

Updated jdbc adapter version above 1.2.6 in Gemfile by trunk r12172 and 2.3-stable r12174.

Also available in: Atom PDF