Defect #15125

Task properties are reverted when doing a task update from firefox.

Added by Mehmet Soyturk about 4 years ago. Updated almost 4 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Resolution:Wont fix Affected version:2.3.1

Description

We many unintended task property changes (the changes of one user is unintendedly reverted by another user).

To reproduce:
  • Open an issue from firefox.
  • Open the same issue in another tab / browser / computer.
  • From the second tab, update task properties that are selected from dropdown lists, such as "Status", "Priority", "Assignee" or "% Done".
  • Hit F5 from the first tab. You will see that the task properties were updated successfully.
  • Then, still in the second tab, click the "Update" link. You will see that still the old values are selected. Add some message and send the form, and the properties are now reverted.

It seems that Firefox, even after a page refresh, tries to remember the options selected by the user. To avoid this, a ctrl-F5 is needed. See also http://stackoverflow.com/questions/1479233/why-doesnt-firefox-show-the-correct-default-select-option


Related issues

Related to Redmine - Defect #14621: AJAX call on the issue form resets data entered during th... Closed
Duplicated by Redmine - Defect #18011: Firefox: Value of a field not updated properly when hitti... Closed

History

#1 Updated by Mehmet Soyturk about 4 years ago

We many unintended task property changes

We get many ...

Reproduced with Firefox 24.0.

#2 Updated by Toshi MARUYAMA about 4 years ago

  • Related to Defect #14621: AJAX call on the issue form resets data entered during the request added

#3 Updated by Toshi MARUYAMA about 4 years ago

Could you reproduce on trunk r12220?
I think #14621 fixed this issue.

#4 Updated by Mehmet Soyturk about 4 years ago

I don't know. I can reproduce it with our internal redmine install (for which I'm just a user and I don't know its version number), and from http://demo.redmine.org (see http://demo.redmine.org/issues/25923).

#5 Updated by Mehmet Soyturk about 4 years ago

But looking at the code, I don't think that #14621 fixes this issue. r12166 depends on the fact that updateIssueFrom is called when a select is modified. With this bug, select is not modified at all, and no updateIssueFrom is called.

#6 Updated by Jean-Philippe Lang almost 4 years ago

  • Status changed from New to Closed
  • Resolution set to Wont fix

Firefox preserves the selected form elements when hitting F5 by design. So when you hit F5 from the first tab, the old values that were present on the issue form are preserved. Use Ctrl+F5 instead to reload the form without preserving selected values.

#7 Updated by Toshi MARUYAMA almost 3 years ago

  • Duplicated by Defect #18011: Firefox: Value of a field not updated properly when hitting F5 added

Also available in: Atom PDF