Defect #1551

Copying issues resets Status

Added by José Campos over 9 years ago. Updated over 3 years ago.

Status:ClosedStart date:2008-06-30
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:Issues
Target version:-
Resolution:Wont fix Affected version:

Description

When an issues is copied from another one (using the copy option at the top-right corner of the page), all fields are preserved except Status that is reset to New.


Related issues

Related to Redmine - Feature #16959: Default status of copying closed issue Closed
Copied to Redmine - Feature #17576: Ability to choose, in administration page, the behaviour ... Closed 2008-06-30

History

#1 Updated by Jean-Philippe Lang over 9 years ago

The copy resets the status by design.
Copying an issue is just like creating a new one. That's why the copy is created with the default status.
If you copy a closed issue, do you really want the copy to be created as closed ?

#2 Updated by José Campos over 9 years ago

"If you copy a closed issue, do you really want the copy to be created as closed ?"

No, you are right. It doesn't male sense. But, otherwise, if the status is assigned (to a particular developer), it helps if the copied issue is assigned too to the same developer (that was what I was looking for).

Nonetheless, it doesn't take much to change the status to Assign by hand.

Thanks.

#3 Updated by Jean-Philippe Lang over 9 years ago

  • Status changed from New to Closed
  • Resolution set to Wont fix

Thanks for the feedback. The current behaviour is the easiest to handle.

#4 Updated by Maik Lindner over 3 years ago

Current behaviour: Copying issues keeps status :( If I copy a closed issue I create a new closed one. Redmine 2.5.1

#5 Updated by Toshi MARUYAMA over 3 years ago

  • Related to Feature #16959: Default status of copying closed issue added

#6 Updated by Anthony HERBÉ about 3 years ago

  • Copied to Feature #17576: Ability to choose, in administration page, the behaviour of status during copying issues added

Also available in: Atom PDF