Feature #16093

Emails sent out by Redmine are identical

Added by Jean-Claude Wippler almost 6 years ago. Updated 10 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Email notifications
Target version:-
Resolution:Duplicate

Description

While starting to use Redmine a lot more, we're running into the issue that all the emails come from a single email address, and they all look the same. This is, in a way, exactly as it should be - but it makes it hard to create rules for filtering and organizing such notifications. It would be nice to have some hint about who generated the email.

I see that GitHub does the same, but with one clever refinement: the email address is the same, but the person's name specified with that address is the name of the originator.

Would it be possible to implement this idea in Redmine? One option I can think of is that some special characters in the email field set in the admin pages get replaced when creating a new email. In our case, that would be the username of the person causing the email to be generated: issue creator, wiki editor, forum poster, etc.

The resulting email would still appear to come from a single email address, but email apps can then show who in the Redmine setup generated the message.

So if the Emission email address field on the Email notifications page is set to say "<<me>> <redmine@example.com>", then this issue would have generated an issue with as sender "jcw <redmine@example.com>". Just enough extra detail for receivers of the email to see who it's really from, even though Redmine generated it.


Related issues

Related to Redmine - Feature #11894: Configurable emission email address Closed
Related to Redmine - Feature #241: Mailer sender is set as event initiator Closed
Duplicates Redmine - Feature #5913: Authors name in from address of email notifications Closed 2010-07-20

History

#1 Updated by Jean-Claude Wippler almost 6 years ago

See also Wim Bertels' last comment at #11894.

#2 Updated by Toshi MARUYAMA almost 6 years ago

  • Related to Feature #11894: Configurable emission email address added

#3 Updated by Toshi MARUYAMA almost 6 years ago

  • Description updated (diff)

#4 Updated by Go MAEDA 10 months ago

  • Related to Feature #241: Mailer sender is set as event initiator added

#5 Updated by Go MAEDA 10 months ago

  • Duplicates Feature #5913: Authors name in from address of email notifications added

#6 Updated by Go MAEDA 10 months ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

I like this idea but closing as a duplicate of #5913.

Also available in: Atom PDF