Defect #1633

Activity pages showing errors and subversion can't integrate

Added by Liju Mathew over 11 years ago. Updated over 11 years ago.

Status:ClosedStart date:2008-07-14
Priority:HighDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:Administration
Target version:-
Resolution:Invalid Affected version:

Description

Hi All,

I have a centos5 server and have redmine 0.7.3 installed. Ruby version is ruby 1.8.7 (2008-06-20 patchlevel 22) [i686-linux] and my gems list are showing below
  • LOCAL GEMS ***

actionmailer (2.1.0, 2.0.2)
actionpack (2.1.0, 2.0.2)
activerecord (2.1.0, 2.0.2)
activeresource (2.1.0, 2.0.2)
activesupport (2.1.0, 2.0.2)
cgi_multipart_eof_fix (2.5.0)
daemons (1.0.10)
fastthread (1.0.1)
gem_plugin (0.2.3)
haml (2.0.1)
mongrel (1.1.5)
rails (2.1.0, 2.0.2)
rake (0.8.1)
tlsmail (0.0.1)

I can able to installed the red mine on the server as per the instructions on the site. I have faced 2 kind of problems.
1, whenever I click on the activity pages it shows internal error and I am stuck with its implementation on the server. Errors are listed below

ActionView::TemplateError (undefined method `length' for #<Enumerable::Enumerator:0xb77e74c8>) on line #7 of projects/activity.rhtml:
4: <h3><%= day_name(day.cwday) > <= day.day ></h3>
5: <ul>
6: <
@events_by_day[day].sort {|x,y| y.event_datetime <=> x.event_datetime }.each do |e| >
7: <li><p><
= format_time(e.event_datetime, false) > <= link_to truncate(e.event_title, 100), e.event_url ><br />
8: <
unless e.event_description.blank? ><em><= truncate(e.event_description, 500) ></em><br />< end >
9: <span class="author"><
= e.event_author if e.respond_to?(:event_author) ></span></p></li>
10: <
end %>

/usr/local/lib/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_view/helpers/text_helper.rb:50:in `truncate'
app/views/projects/activity.rhtml:7:in `_run_erb_47app47views47projects47activity46rhtml'
app/views/projects/activity.rhtml:6:in `each'
app/views/projects/activity.rhtml:6:in `_run_erb_47app47views47projects47activity46rhtml'
app/views/projects/activity.rhtml:3:in `each'
app/views/projects/activity.rhtml:3:in `_run_erb_47app47views47projects47activity46rhtml'
/usr/local/lib/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_view/base.rb:637:in `send'
/usr/local/lib/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_view/base.rb:637:in `compile_and_render_template'
/usr/local/lib/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_view/base.rb:365:in `render_template'
/usr/local/lib/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_view/base.rb:316:in `render_file'
/usr/local/lib/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/base.rb:1100:in `render_for_file'
/usr/local/lib/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/base.rb:836:in `render_with_no_layout'
/usr/local/lib/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/layout.rb:262:in `render_without_benchmark'
/usr/local/lib/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/benchmarking.rb:51:in `render'
/usr/local/lib/ruby/1.8/benchmark.rb:293:in `measure'
/usr/local/lib/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/benchmarking.rb:51:in `render'
/usr/local/lib/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/base.rb:1153:in `default_render'
/usr/local/lib/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/base.rb:1159:in `perform_action_without_filters'
/usr/local/lib/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/filters.rb:697:in `call_filters'
/usr/local/lib/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/filters.rb:689:in `perform_action_without_benchmark'
/usr/local/lib/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/benchmarking.rb:68:in `perform_action_without_rescue'
2. Whenever I am trying to integrate subversion with redmine, I am getting the error "Entry and/or revision doesn't exist in the repository". We are using http method to connect svn. Is that issue with SVN ?. I have restored the database from the server and it works successfully on my desktop without showing any issue either on "activity" tab or "repository" tab.
I am also getting the svn checkout error from the terminal.
svn: The path was not part of a repository
svn: PROPFIND request failed on '/'
svn: '/' path not found

Can anybody tell me that what wouldb be the wrong with My redmine.

Any comments greatly appreciated,
Liju

activity.rhtml Magnifier (2.01 KB) Liju Mathew, 2008-07-14 12:55

History

#1 Updated by Liju Mathew over 11 years ago

Hi,

I have resolved the issue with activity pages.I replacecd the attached page (activity.rhtml) with redmine file .It's truncate function error. But repository module still showing the error "Entry and/or revision doesn't exist in the repository".

My subversion is 1.4.5 and rails is 2.1.0 version. I can able to check the repository manually and also can able to integrate it with local redmine.

Whenever I try to checkout from the terminal, I got the following error. This problem exist only on server and repository is also working well.

svn co http://subversion.mydomain.com/myproject/
svn: The path was not part of a repository
svn: PROPFIND request failed on '/'
svn: '/' path not found

Pls guide me.

Thanks,
Liju

#2 Updated by Jean-Philippe Lang over 11 years ago

  • Status changed from Resolved to Closed
  • Target version deleted (0.7.3)
  • Affected version (unused) deleted (0.7.3)
  • Resolution set to Invalid
  • Affected version deleted (0.7.3)

0.7.3 is not compatible with Rails 2.1 and ruby 1.8.7. Please read RedmineInstall.
You will find the cause of your PROPFIND error on this page: Download.

Also available in: Atom PDF