Defect #16338

Can't choose an issue of a different project when updating time entries

Added by Bernhard Kraft almost 4 years ago. Updated almost 4 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:Time tracking
Target version:2.5.1
Resolution:Fixed Affected version:2.5.0

Description

When changing a ticket ID of a time tracker entry an error message about invalid ticket ("Ticket ist nicht g├╝ltig") show up.

Altough the correct ticket title gets shown.

Steps to reproduce:
1. Create a time tracker entry for some ticket
2. Use the "My page" view to edit the created time tracker entry
3. Change the ticket id to another valid ticket

Screenshot attached

time_tracker_bug.png (14 KB) Bernhard Kraft, 2014-03-13 11:09

Associated revisions

Revision 12990
Added by Jean-Philippe Lang almost 4 years ago

Let user choose an issue of another project when updating a time entry (#16338).

History

#1 Updated by Bernhard Kraft almost 4 years ago

This bug only exists since upgrading to 2.5.0

#2 Updated by Jean-Philippe Lang almost 4 years ago

  • Status changed from New to Needs feedback
  • Assignee set to Jean-Philippe Lang

I guess it only happens when the ticket chosen in step 3. is not in the same project as the original ticket, right?

#3 Updated by Jean-Philippe Lang almost 4 years ago

  • Subject changed from Can't change ticket ID of time tracker entries to Can't choose an issue of a different project when updating time entries
  • Status changed from Needs feedback to Resolved
  • Target version set to 2.5.1
  • Resolution set to Fixed

Fixed in r12990.

#4 Updated by Jean-Philippe Lang almost 4 years ago

  • Status changed from Resolved to Closed

Merged.

Also available in: Atom PDF