Defect #17057

Private Notes

Added by James H over 3 years ago. Updated 9 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues permissions
Target version:-
Resolution:Duplicate Affected version:2.4.2

Description

Should private notes be viewable by the person that wrote them?

In my case, only the owner of the issue is able to view all the notes on that issue. Individuals can write private notes to the issues, but after updating with the note, it is not visible to the respective individuals.


Related issues

Related to Redmine - Defect #17632: Users can't see private notes created by themselves if "M... Closed

History

#1 Updated by Jan Niggemann (redmine.org team member) over 3 years ago

  • Status changed from New to Closed
  • Resolution set to Invalid

James H wrote:

Should private notes be viewable by the person that wrote them?

IMHO yes...

In my case, only the owner of the issue is able to view all the notes on that issue. Individuals can write private notes to the issues, but after updating with the note, it is not visible to the respective individuals.

Your usecase might be different, but anyway, this is not a defect.
Please use the forums for general questions, thank you.

#3 Updated by James H over 3 years ago

still trying to get some attention from a dev.... that is my thread.

#4 Updated by James H over 2 years ago

  • Status changed from Closed to Reopened

is it okay to reopen this now or do we still need verification that its a defect.

#5 Updated by JW Fuchs about 1 year ago

+1

Also see #17632

#6 Updated by Toshi MARUYAMA about 1 year ago

  • Related to Defect #17632: Users can't see private notes created by themselves if "Mark notes as private" is set but "View private notes" is not added

#7 Updated by Stephane Evr 11 months ago

+1

#8 Updated by Peter Puff 9 months ago

+1

#9 Updated by Jean-Philippe Lang 9 months ago

  • Status changed from Reopened to Closed
  • Resolution changed from Invalid to Duplicate

Fixed in #17632 for 3.4.0

Also available in: Atom PDF