Feature #17582

advanced awesome calculated computed custom fields

Added by Alex Alex over 3 years ago. Updated over 2 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Custom fields
Target version:-
Resolution:Duplicate

Description

I didn't find this in features or in plugins.

The guys from EasyRedmine did great job, but when I contacted them, they said that Calculated (computed) custom fields supported only EasyRedmine, it doesn't work with Redmine-Core. It's really pitty.

1. develop or adapt Calculated (computed) custom fields (scren) for Redmine-Core
2. Improve functionality. Add сalculation by taking a sample of data from other issues(custom fields,fields).
Because now, (1) calculate data only from 1 issue. We need

For example We have issue with tracker "Invoice" and custom fields: a) invoice_income, b) invoice_expences
And We have issue "Contact" with custom fields %Revenue_per_month
Please see

advanced awesome calculated computed custom fields.png (39.6 KB) Alex Alex, 2014-07-30 10:22


Related issues

Related to Redmine - Feature #17535: Custom fields maths Closed
Duplicated by Redmine - Feature #17913: Formula based custom field calculation Closed
Duplicates Redmine - Feature #1712: add custom fields that are calculations of other fields New 2008-07-30
Duplicates Redmine - Feature #8177: Custom Field with mathematical calculation New 2011-04-18

History

#1 Updated by Toshi MARUYAMA over 3 years ago

  • Priority changed from Urgent to Normal

#2 Updated by ami desai about 3 years ago

Even i need the same functionality.

#3 Updated by Alex Alex about 3 years ago

ami desai wrote:

Even i need the same functionality.

Thanks!
Toshi, +1

#4 Updated by cody liou about 3 years ago

+1
i need the same functionality.

#5 Updated by Toshi MARUYAMA about 3 years ago

  • Duplicated by Feature #17913: Formula based custom field calculation added

#6 Updated by ami desai about 3 years ago

+1

#7 Updated by ami desai about 3 years ago

+1

#8 Updated by John Gordon almost 3 years ago

+1 see #17535
#17913 has been closed as a duplicated ticket but no further response provided here about the feature request given the Easy Redmine solution does not work on Redmine Core.

#9 Updated by Toshi MARUYAMA almost 3 years ago

#10 Updated by Ferenc Sági over 2 years ago

+1

#11 Updated by Sebastian Paluch over 2 years ago

+1000

and duplicates #1712.

#12 Updated by Toshi MARUYAMA over 2 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Sebastian Paluch wrote:

and duplicates #1712.

Thank you for your pointing out.

#13 Updated by Toshi MARUYAMA over 2 years ago

  • Duplicates Feature #1712: add custom fields that are calculations of other fields added

#14 Updated by Toshi MARUYAMA over 2 years ago

And duplicate of #8177.

#15 Updated by Toshi MARUYAMA over 2 years ago

  • Duplicates Feature #8177: Custom Field with mathematical calculation added

Also available in: Atom PDF