Defect #17970

Wiki PDF export doesn't render macros

Added by Fabian Strasser about 3 years ago. Updated about 3 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:PDF export
Target version:-
Resolution:Duplicate Affected version:2.5.1

Description

This is something bugging me for quite some time now, but so far I haven't found a solution:

When you export a wiki site that uses macros to PDF the output doesn't show the rendered/parsed state but only the source-code which isn't useful at all (see attached images). The page should be rendered first, then be converted to PDF.

This is also related to another issue/feature request I have: #17238. There the same problems bugs me, but not for the PDF export, but for the search function.

01.jpg - That's the wiki page (24.9 KB) Fabian Strasser, 2014-09-26 11:30

02.jpg - That's the exported PDF (38.7 KB) Fabian Strasser, 2014-09-26 11:30


Related issues

Duplicates Redmine - Feature #13051: Support any macro in (pdf) export for wiki's and issues Closed

History

#1 Updated by Fabian Strasser about 3 years ago

That's the wiki page
↑ Wiki-page ↑

↓ PDF export ↓
That's the exported PDF

#2 Updated by Toshi MARUYAMA about 3 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Duplicate of #13051.

#3 Updated by Toshi MARUYAMA about 3 years ago

  • Duplicates Feature #13051: Support any macro in (pdf) export for wiki's and issues added

Also available in: Atom PDF