Defect #18176

PDF: long text is corrupt

Added by Felix Muster almost 4 years ago. Updated almost 4 years ago.

Status:ClosedStart date:
Priority:UrgentDue date:
Assignee:-% Done:

0%

Category:PDF export
Target version:2.6.1
Resolution:Fixed Affected version:2.6.0

Description

I applied the pdf.rb.patch from #14466 in my old Redmine Version 2.5.

I updated to 2.6.0.
But there is still the problem that an export of issues with long text to pdf is corrupt.

The pdf.rb file was heavily adjusted.
So the patch doesn't take an affect.

I tried a bit on my own.
But I'm really new on ruby.

Could you please give me quick support?
It's an important feature for us.

Thank you.

im-496.pdf - pdf export 2.5.0 (314 KB) Felix Muster, 2014-10-24 11:53

im-496-2r.pdf - pdf export 2.6.0 (119 KB) Felix Muster, 2014-10-24 11:53

fertigung-2-0-1083.pdf - Export of a single issue (v2.6.0) (326 KB) Felix Muster, 2014-10-24 12:07

issues.pdf - Export of query of issues (v2.6.0) (313 KB) Felix Muster, 2014-10-24 12:08

redmine_pdf.png - long text result (65.9 KB) Jun NAITOH, 2014-10-24 17:21

Associated revisions

Revision 13506
Added by Toshi MARUYAMA almost 4 years ago

Gemfile: update rbpdf to version 1.18.2 (#18176)

Revision 13507
Added by Toshi MARUYAMA almost 4 years ago

Merged r13506 from trunk to 2.6-stable (#18176)

Gemfile: update rbpdf to version 1.18.2.

History

#1 Updated by Toshi MARUYAMA almost 4 years ago

  • Category set to PDF export

#3 Updated by Felix Muster almost 4 years ago

wonderful.
Hope we get an answer soon ;)
Thanks.

#4 Updated by Felix Muster almost 4 years ago

I researched a bit and noticed the following:

The problem is still given but in an other way!

The text overrun changed from left to right to top to bottom (See attached pdfs!)

#5 Updated by Felix Muster almost 4 years ago

The defect is limited when I export a single issue.

But when I export a query of issues it looks like the attached pdf.

#6 Updated by Jun NAITOH almost 4 years ago

I can't reproduced.

long text result

please tell me your environment.

#7 Updated by Jun NAITOH almost 4 years ago

Felix Muster wrote:

But when I export a query of issues it looks like the attached pdf.

issues.pdf - Export of query of issues (v2.6.0)

ok, I can reproduced issues.pdf.

#8 Updated by Jun NAITOH almost 4 years ago

I released rbpdf 1.18.2 gem.
fixed this problem.

please bundle update

bundle update rbpdf

#9 Updated by Toshi MARUYAMA almost 4 years ago

  • Subject changed from PDF Export still corrupt to PDF: long text is corrupt
  • Target version set to 2.6.1

#10 Updated by Toshi MARUYAMA almost 4 years ago

  • Status changed from New to Closed
  • Resolution set to Fixed

Gem version has updated in trunk r13506 and 2.6-stable r13507, thanks.

#11 Updated by Felix Muster almost 4 years ago

Works perfectly

thank you!

Also available in: Atom PDF