Feature #18212

The status of parent issue could be changed to closed before all of the sub issues' status are changed to closed

Added by Haiyang He almost 3 years ago. Updated almost 3 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:Duplicate

Description

I have fixed this issue on my local redmine.

Add the following code after the 73 line of app/models/issue.rb

validate :closed_before_sub_issues

Add the closed_before_sub_issues method:

def closed_before_sub_issues
    closedIssueStatus = IssueStatus.find_by_is_closed true
    if closedIssueStatus && status_id == closedIssueStatus.id
      if descendants.any? { |childIssue| childIssue.status_id != closedIssueStatus.id}
        errors.add :status_id, :cant_close_before_sub_issues_closed
      end
    end
  end

Add error message in the en.yml:
cant_close_before_sub_issues_closed: can change the status to closed before the all the sub issue are not closed


Related issues

Duplicates Redmine - Feature #10989: Prevent parent issue from being closed if a child issue i... Closed

History

#1 Updated by Toshi MARUYAMA almost 3 years ago

  • Description updated (diff)
  • Category set to Issues

#2 Updated by Toshi MARUYAMA almost 3 years ago

  • Tracker changed from Defect to Feature
  • Status changed from New to Closed
  • Resolution set to Duplicate

Duplicate of #10989.

#3 Updated by Toshi MARUYAMA almost 3 years ago

  • Duplicates Feature #10989: Prevent parent issue from being closed if a child issue is open added

Also available in: Atom PDF