Feature #1860

reST (reStructuredText) support

Added by Daniel Srb about 9 years ago. Updated almost 8 years ago.

Status:ClosedStart date:2008-09-05
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Wiki
Target version:-
Resolution:Duplicate

Description

Textile is nice but sometimes not powerful enough. There I see a place for reStructuredText formatting.

Of course as an option, textile is definitely suitable for many projects. It would be great addition especially for those who migrate from trac.

Nice to have: wiki syntax could be chosen per project.

As a non-programmer I can't see the complexity of this, but I can imagine, that somebody's got other favorite syntax and would like to have it available in Redmine and would add the parser if there was some standard interface to do that.


Related issues

Duplicates Redmine - Feature #1208: Restructured text support for the wiki New 2008-05-08

History

#1 Updated by Paul Rivier about 9 years ago

It is indeed technically feasible, but could you please elaborate on "Textile is [snip] not powerful enough" so that we know exactly what is lacking.

#2 Updated by James Turnbull about 9 years ago

Also duplicate of #1208

#3 Updated by Daniel Srb about 9 years ago

James: I'll try to search more thoroughly next time.

Paul:

  Place you code here.

Textile is a way to write HTML more effective way.

ReST is a way to write plain text that is parseable but also looking "formatted" in plain text view. That is probably why it's standard Python way of writing documentation and that's why nearly every single colleague of mine who is a Python developer asked me about ReST support after Trac2Redmine migration.

As I read through other textile/wiki formatting threads and issues here, I suppose more (and good enough) would be support for different formatting in Trac way (marking block of differently formatted with start and end sequence). Much bigger problem seems to be what James wrote in #1208 about non-existence of Ruby parser for ReST.

#4 Updated by Daniel Srb about 9 years ago

Daniel Srb wrote:

[...]

oops i forgot something there... please ignore the code . )

#5 Updated by Karl Heinz Marbaise almost 9 years ago

  • Category set to Wiki

#6 Updated by Manuel Vázquez Acosta almost 8 years ago

  • Status changed from New to Resolved

This is a dupe of #1208.

#7 Updated by Jean-Philippe Lang almost 8 years ago

  • Status changed from Resolved to Closed
  • Resolution set to Duplicate

Also available in: Atom PDF