Defect #18685

Plugin migration confuses two plugins with similar names

Added by Kevin Neuenfeldt almost 4 years ago. Updated almost 4 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:Plugin API
Target version:2.6.1
Resolution:Fixed Affected version:

Description

Environment:
  Redmine version                2.5.1.stable
  Ruby version                   2.1.5-p273 (2014-11-13) [i386-linux]
  Rails version                  3.2.17
  Environment                    production
  Database adapter               Mysql2
Redmine plugins:
  buildversion_manager           0.0.1
  enervision_customization       0.1.1
  extended_gantt                 0.2.0
  issue_repo_history_merge       0.0.2
  multi_time_tracker             0.1.2
  once_assigned_ever_watcher     0.1.0
  redmine_proxy                  0.0.1
  redmine_re                     development version
  redmine_reminder               0.3.0
  redmine_wiki_lists             0.0.3
  stuff_to_do_plugin             0.4.2
  work_performance_record_to_pdf 0.0.1

The following situation:

I have a Redmine 2.5.1 instance running several plugins. One of them is called redmine_reminder, the other one redmine_re. redmine_reminder was installed before redmine_re and has four migration steps.
Now when I tried to migrate redmine_re migration started with the fifth migration step. Unnecessary to say that it did not succeed.

In the end I managed to install both plugins by rolling back redmine_reminder to version 0, fixing the broken migrations of redmine_re by hand and then installing redmine_re first followed by redmine_reminder.
For some reason the migration of redmine_re started at step five because of the 0-redmine_reminder entry in schema_migrations. As soon as these entries were gone because of the rollback the migration of redmine_re started with step 0.

So it looks like the migration for redmine_re saw that there is something in schema_migrations (namely redmine_reminder) that is similar and therefore started with the fifth step.

I don't know if this is a job for the Redmine developers or for the Rails developers so I post it here first.

Associated revisions

Revision 13768
Added by Jean-Philippe Lang almost 4 years ago

Plugin migration confuses two plugins with similar names (#18685).

History

#1 Updated by Jean-Philippe Lang almost 4 years ago

  • Category changed from Rails support to Plugin API
  • Status changed from New to Confirmed

#2 Updated by Jean-Philippe Lang almost 4 years ago

  • Status changed from Confirmed to Resolved
  • Assignee set to Jean-Philippe Lang
  • Target version set to 2.6.1
  • Resolution set to Fixed

This should be fixed by r13768, thanks for reporting this.

#3 Updated by Jean-Philippe Lang almost 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF