Defect #18850

Multiple repos with same commits is parsed multiple times.

Added by Simen Endsj√ł almost 3 years ago. Updated almost 3 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:SCM
Target version:-
Resolution:Duplicate Affected version:2.5.2

Description

We have a setup with a main repo and a repo for each user.
The reason for this is to get updates quickly while users are working on features before the changes are merged into the main repo.

The problem is when other repos are getting the changes merged in.
Even though the commit hashes is equal, Redmine parses them again.
This makes all issues get multiple references to (the same) commits, and all logged time to be logged again.

Is this a bug? And is there a way to get around this issue?


Related issues

Duplicates Redmine - Defect #17931: note "Applied in changeset" generated multiple times for ... Closed

History

#1 Updated by Toshi MARUYAMA almost 3 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Duplicate of #17931.

#2 Updated by Toshi MARUYAMA almost 3 years ago

  • Duplicates Defect #17931: note "Applied in changeset" generated multiple times for the same repo added

Also available in: Atom PDF