Defect #18896

Grouping of Boolean field in Query: group not displayed for "No" value if the group is in first position

Added by kaz k almost 3 years ago. Updated almost 3 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:Custom fields
Target version:2.6.2
Resolution:Fixed Affected version:2.5.0

Description

When I submit the query with "Group results by" the boolean field which is defined as "required" , collapse/expand indicator line for "No" is not displayed.
  • Tickets are distinguished into 2 groups, one for "No" and the other for "Yes". OK.
  • But collapse/expand indicator line for "No" is not displayed. It should be displayed, I think.
    • On the other hand, collapse/expand indicator line for "Yes" is displayed. OK.

I'd appreciate if this issue is picked up and will be examined/fixed.

Kind regards,


  • Reported version
    Redmine 2.5.0.stable.
    Details are as follows.
    1. Test redmine (Windows7)
      Environment:
        Redmine version                2.5.0.stable
        Ruby version                   1.9.3-p231 (2012-05-25) [i386-mingw32]
        Rails version                  3.2.17
        Environment                    production
        Database adapter               Mysql2
      
    2. Production redmine (Linux)
      Environment:
        Redmine version                2.5.0.stable
        Ruby version                   1.9.3-p484 (2013-11-22) [x86_64-linux]
        Rails version                  3.2.17
        Environment                    production
        Database adapter               PostgreSQL
      

Note: This phenomena does not happen with a boolean field which is not defined as "required". In this case, 3 collapse/expand indicator lines are displayed (with misleading labels ( see #18894 ) when this ticket is created).

03_English_QueryResult_GroupedByBoolean(required)_NoIsGroupedWithoutCollapse-Expand-Indicatorline.jpg - screen capture of query-result grouped by boolean field (specified as equired) (105 KB) kaz k, 2015-01-19 08:33

2.6.1.png (34.9 KB) Toshi MARUYAMA, 2015-01-19 08:47

2.6.1-confirmed.png (16.9 KB) Toshi MARUYAMA, 2015-01-19 10:50

Associated revisions

Revision 13922
Added by Jean-Philippe Lang almost 3 years ago

Fixed that group is not displayed when the first group is a boolean custom field group with "No" value (#18896).

History

#1 Updated by kaz k almost 3 years ago

Screen capture
Here is a screen capture of query-result grouped by boolean field.
In the picture, Boolean2required is a boolean filed with "required" specification.
You could see 2 groups of tickets, one for "No" and the other is "Yes".
But "No" tickets do not have collapse/expand indicator line of "No" at the top of the tickets. "Yes" tickets have one for "Yes".

#2 Updated by Toshi MARUYAMA almost 3 years ago

  • File 2.6.1.png added
  • Status changed from New to Needs feedback

I cannot reproduce on 2.6.1.

#3 Updated by kaz k almost 3 years ago

Toshi MARUYAMA wrote:

I cannot reproduce on 2.6.1.

Thank you for your quick reply.

According to the picture attached, it seems the boolean field has an attribute of "Not REQUIRED" because the list is grouped in 3 groups, 2 of "none" and 1 of "Yes".
As I write in the description, the phenomena happens if the boolean fields is defined as "Required", ie. Values are only 2 variations of "Yes" and "No".

#4 Updated by Toshi MARUYAMA almost 3 years ago

  • File 2.6.1-confirmed.png added
  • Status changed from Needs feedback to Confirmed
  • Target version set to 2.6.2

Confirmed.

#5 Updated by kaz k almost 3 years ago

Toshi MARUYAMA wrote:

Confirmed.

Thank you.

#6 Updated by Jean-Philippe Lang almost 3 years ago

  • Subject changed from Grouping of Boolean field in Query: collapse/expand indicator line is not displayed for "No" value. to Grouping of Boolean field in Query: group not displayed for "No" value if the group is in first position
  • Status changed from Confirmed to Resolved
  • Assignee set to Jean-Philippe Lang
  • Resolution set to Fixed

Fixed in r13922, thanks for pointing this out.

#7 Updated by Jean-Philippe Lang almost 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF