Defect #19033

Filters that utilize date/time ignore user's UTC offset

Added by Zach N almost 3 years ago. Updated over 1 year ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Resolution: Affected version:2.5.2

Description

Description:

Using any filter that uses date/time, such as "Today," "Yesterday," is Date, etc. ignores the UTC offset of the user.
Attached is a screenshot. In the screenshot is an issue with the date, 2/3/2015 @ 1807 CST. Converting this date to UTC would make it 2/4/2015 0007 UTC.

The server is set to UTC time. The Redmine config is using "local" for timezone. The user in the example has their UTC offset set to -6 or Central Standard Time.

Expected:

I expect any filter using date/time to take into account the time offset the user has provided within their account profile.

Instillation Info:

Environment:
Redmine version 2.5.2.stable
Ruby version 1.9.3-p547 (2014-05-14) [x86_64-linux]
Rails version 3.2.19
Environment production
Database adapter Mysql2
SCM:
Subversion 1.8.8
Mercurial 2.1
Cvs 1.12.13
Git 1.9.0
Filesystem
Redmine plugins:
redmine_time_tracker 0.5

DateTime_Bug_Redmine_Screenshot.png (25.6 KB) Zach N, 2015-02-04 20:25


Related issues

Related to Redmine - Patch #20473: Respect the user's timezone when querying issues Closed
Related to Redmine - Defect #16482: Wrong search query for timelog, when timezone not UTC New
Duplicates Redmine - Patch #22320: Respect user's timezone when comparing / parsing Dates Closed

History

#1 Updated by Sebastian Paluch almost 2 years ago

Patch for this #20473.

#2 Updated by Toshi MARUYAMA almost 2 years ago

  • Related to Patch #20473: Respect the user's timezone when querying issues added

#3 Updated by Scott Macpherson almost 2 years ago

Duplicate of #16482?

#4 Updated by Jan from Planio www.plan.io over 1 year ago

  • Duplicates Patch #22320: Respect user's timezone when comparing / parsing Dates added

#5 Updated by Toshi MARUYAMA over 1 year ago

  • Related to Defect #16482: Wrong search query for timelog, when timezone not UTC added

#6 Updated by Jean-Philippe Lang over 1 year ago

  • Status changed from New to Closed

Committed, thanks.

Also available in: Atom PDF