Defect #19114

Cannot archive projects

Added by Aron Rotteveel over 2 years ago. Updated over 2 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Projects
Target version:-
Resolution:Invalid Affected version:

Description

Hi,

I just just updated (gulp) from 2.3.1 to 2.6.1.stable.14014 and find I can no longer archive projects.
What could be causing this?

My log:

ActionController::RoutingError (No route matches [GET] "/projects/[redacted]/archive"):
  vendor/cache/ruby/1.9.1/gems/actionpack-3.2.21/lib/action_dispatch/middleware/debug_exceptions.rb:21:in `call'
  vendor/cache/ruby/1.9.1/gems/actionpack-3.2.21/lib/action_dispatch/middleware/show_exceptions.rb:56:in `call'
  vendor/cache/ruby/1.9.1/gems/railties-3.2.21/lib/rails/rack/logger.rb:32:in `call_app'
  vendor/cache/ruby/1.9.1/gems/railties-3.2.21/lib/rails/rack/logger.rb:16:in `block in call'
  vendor/cache/ruby/1.9.1/gems/activesupport-3.2.21/lib/active_support/tagged_logging.rb:22:in `tagged'
  vendor/cache/ruby/1.9.1/gems/railties-3.2.21/lib/rails/rack/logger.rb:16:in `call'
  vendor/cache/ruby/1.9.1/gems/actionpack-3.2.21/lib/action_dispatch/middleware/request_id.rb:22:in `call'
  vendor/cache/ruby/1.9.1/gems/rack-1.4.5/lib/rack/methodoverride.rb:21:in `call'
  vendor/cache/ruby/1.9.1/gems/rack-1.4.5/lib/rack/runtime.rb:17:in `call'
  vendor/cache/ruby/1.9.1/gems/activesupport-3.2.21/lib/active_support/cache/strategy/local_cache.rb:72:in `call'
  vendor/cache/ruby/1.9.1/gems/rack-1.4.5/lib/rack/lock.rb:15:in `call'
  vendor/cache/ruby/1.9.1/gems/actionpack-3.2.21/lib/action_dispatch/middleware/static.rb:83:in `call'
  vendor/cache/ruby/1.9.1/gems/rack-cache-1.2/lib/rack/cache/context.rb:136:in `forward'
  vendor/cache/ruby/1.9.1/gems/rack-cache-1.2/lib/rack/cache/context.rb:245:in `fetch'
  vendor/cache/ruby/1.9.1/gems/rack-cache-1.2/lib/rack/cache/context.rb:185:in `lookup'
  vendor/cache/ruby/1.9.1/gems/rack-cache-1.2/lib/rack/cache/context.rb:66:in `call!'
  vendor/cache/ruby/1.9.1/gems/rack-cache-1.2/lib/rack/cache/context.rb:51:in `call'
  vendor/cache/ruby/1.9.1/gems/railties-3.2.21/lib/rails/engine.rb:484:in `call'
  vendor/cache/ruby/1.9.1/gems/railties-3.2.21/lib/rails/application.rb:231:in `call'
  vendor/cache/ruby/1.9.1/gems/railties-3.2.21/lib/rails/railtie/configurable.rb:30:in `method_missing'
  /usr/lib/ruby/vendor_ruby/phusion_passenger/rack/thread_handler_extension.rb:74:in `process_request'
  /usr/lib/ruby/vendor_ruby/phusion_passenger/request_handler/thread_handler.rb:141:in `accept_and_process_next_request'
  /usr/lib/ruby/vendor_ruby/phusion_passenger/request_handler/thread_handler.rb:109:in `main_loop'
  /usr/lib/ruby/vendor_ruby/phusion_passenger/request_handler.rb:455:in `block (3 levels) in start_threads'

History

#1 Updated by Toshi MARUYAMA over 2 years ago

  • Status changed from New to Resolved

See Submissions.

I cannot reproduce.

ActionController::RoutingError (No route matches [GET] "/projects/[redacted]/archive"):

Route is defined as POST.
source:tags/2.6.1/config/routes.rb#L96

#2 Updated by Toshi MARUYAMA over 2 years ago

  • Status changed from Resolved to Needs feedback

Sorry, I mistook changing status.

#3 Updated by Aron Rotteveel over 2 years ago

Thanks for the quick reply. I solved the issue just now.

The solution was to completely re-install Redmine. It turned out I had quite a lot of artifacts remaining from my old 2.3 installation. I backed up my own configuration + files, removed Redmine, reinstalled the 2.6 branch and moved my own files back. Everything is working fine now.

Hope this helps someone!

#4 Updated by Toshi MARUYAMA over 2 years ago

  • Status changed from Needs feedback to Closed
  • Resolution set to Invalid

Thank you for your feedback.

Also available in: Atom PDF