Defect #19438

Webrick WARN: "Could not determine content-length of response body"

Added by Tobias Fischer over 2 years ago. Updated about 2 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Attachments
Target version:-
Resolution: Affected version:3.0.1

Description

Extracted from issue #19435:

Webrick WARNing in Redmine 3.0.1:

[2015-03-21 14:15:15] WARN  Could not determine content-length of response body. Set content-length of the response or set Response#chunked = true

Happens for all attachments (even images) when trying to download them.
Download works as expected, but the filesize is unknown.
Seems as if the HTTP header can't be set.

This wasn't a problem in redmine 2.6


Related issues

Related to Redmine - Defect #17403: Unknown file size while downloading attachment Closed

History

#1 Updated by Go MAEDA over 2 years ago

This can be fixed by #17403#note-3.
Looks like duplicate of #17403.

#2 Updated by Toshi MARUYAMA over 2 years ago

  • Related to Defect #17403: Unknown file size while downloading attachment added

#3 Updated by Go MAEDA about 2 years ago

  • Status changed from New to Closed

Fixed in r14632.
Thanks for reporting this issue.

Also available in: Atom PDF