Defect #19523

problem in exporting Arabic text to csv

Added by vijay krishna over 2 years ago. Updated over 2 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:I18n
Target version:-
Resolution:Duplicate Affected version:2.6.2

Description

We have problem in exporting arabic text to excel in csv format using english locale.
we have changed "general_csv_encoding: UTF-8" in en.yml config file. Please help on this.

issues.xlsx (36.2 KB) vijay krishna, 2015-03-30 11:29

en.yml Magnifier (48 KB) vijay krishna, 2015-03-30 11:29

issuesreported.xlsx (144 KB) vijay krishna, 2015-04-01 10:34

issuesreported.xlsx (155 KB) vijay krishna, 2015-04-01 12:07

Issues.xlsx (29.2 KB) vijay krishna, 2015-04-06 11:47


Related issues

Related to Redmine - Feature #7037: CSV export encoding and excel. UTF-8 and BOM Closed 2010-12-03
Duplicates Redmine - Defect #11116: CSV export encoding problem when issues and interface lan... Closed

History

#1 Updated by Toshi MARUYAMA over 2 years ago

  • Subject changed from problem in exporting Arabic text to csv using english locale to problem in exporting Arabic text to csv

#2 Updated by Toshi MARUYAMA over 2 years ago

  • Priority changed from Urgent to Normal

#3 Updated by Toshi MARUYAMA over 2 years ago

I don't know what Arabic standard code page is.
http://en.wikipedia.org/wiki/Windows-1256

#4 Updated by vijay krishna over 2 years ago

i tried to change the "general_csv_encoding: Windows-1256" also, but still same issue.
Checked in my sql db the the arabic text is saving correctly, attaching the document for your reference.
Please help to suggest on this.

#5 Updated by vijay krishna over 2 years ago

i have created issue #19543 to replicate the issue here in this forum. same problem i am getting while exporting this to csv format. Please help on this.

#6 Updated by vijay krishna over 2 years ago

Is this a limitation? can someone respond please.

#7 Updated by Toshi MARUYAMA over 2 years ago

http://stackoverflow.com/a/1502134

Excel uses the machine-specific ANSI encoding.

It seems you uses English Windows.
In this case you need to set UTF-8 in en.yml
and convert to Arabic encoding.
https://www.google.co.jp/search?q=excel%20utf-8

#8 Updated by Toshi MARUYAMA over 2 years ago

  • Related to Feature #7037: CSV export encoding and excel. UTF-8 and BOM added

#9 Updated by Toshi MARUYAMA over 2 years ago

  • Category changed from Issues to I18n

Try #7037#note-11 patch.

#10 Updated by Toshi MARUYAMA over 2 years ago

Toshi MARUYAMA wrote:

It seems you uses English Windows.
In this case you need to set UTF-8 in en.yml
and convert to Arabic encoding.

Sorry, it is wrong.
There is no easy way.
Try #7037#note-12 patch.

#11 Updated by Toshi MARUYAMA over 2 years ago

Toshi MARUYAMA wrote:

Toshi MARUYAMA wrote:

It seems you uses English Windows.
In this case you need to set UTF-8 in en.yml
and convert to Arabic encoding.

Sorry, it is wrong.
There is no easy way.

Try this.
http://stackoverflow.com/a/11249968

#12 Updated by vijay krishna over 2 years ago

Getting below error while trying to install the "redmine_csv_with_bom-master" plugin. please see attached for reference.

#13 Updated by vijay krishna over 2 years ago

D:\redmine-2.5.1>rake redmine:plugins:migrate RAILS_ENV=production
rake aborted!
NameError: undefined method `issues_to_csv' for module `IssuesHelper'
D:/redmine-2.5.1/plugins/redmine_csv_with_bom-master/init.rb:4:in `block in <top
(required)>'
D:/redmine-2.5.1/plugins/redmine_csv_with_bom-master/init.rb:3:in `module_eval'
D:/redmine-2.5.1/plugins/redmine_csv_with_bom-master/init.rb:3:in `<top (require
d)>'
D:/redmine-2.5.1/lib/redmine/plugin.rb:150:in `block in load'
D:/redmine-2.5.1/lib/redmine/plugin.rb:141:in `each'
D:/redmine-2.5.1/lib/redmine/plugin.rb:141:in `load'
D:/redmine-2.5.1/config/initializers/30-redmine.rb:19:in `<top (required)>'
D:/redmine-2.5.1/config/environment.rb:14:in `<top (required)>'
Tasks: TOP => redmine:plugins:migrate => environment
(See full trace by running task with --trace)

#14 Updated by Toshi MARUYAMA over 2 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Duplicate of #11116.

#15 Updated by Toshi MARUYAMA over 2 years ago

  • Duplicates Defect #11116: CSV export encoding problem when issues and interface languages are not equal added

Also available in: Atom PDF